Jump to content


Photo

Linksprite Far Range Integrated RFID Reader LSID-0703


  • Please log in to reply
6 replies to this topic

#1 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 29 August 2014 - 02:04 AM

Does the LSID-0703 reader use the same serial communications protocol as the LSID-0702? I have been having problems reading tags.

For example, when the reader is in "active sending" read mode, the reader WILL recognize tags, but the buffer doesn't look anything like the 'Linksprite Long Distance RFID Reader Communication Protocol' document. Usually, it will print a 4 or so characters per tag read, and will look like:

"c4 fe" 

instead of something like
"CCFFFF01080125001100ABEEAFC1EC88851ADA"

I am using EPC Gen 2 windshield tags and keyfobs that shipped from linksprite with the reader.

Other questions might be; what is the default baud rate that the device ships with? It appears to be 9600.

Are there any guides besides the ones for the LSID-0702 reader that I need to be aware of? thank you!



#2 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 29 August 2014 - 02:29 AM

Yes, they have the same communication protocol. The default baud rate should be 9600.

 

Did you try to use the demo program: https://s3.amazonaws...RFID reader.zip

 

0702 6


#3 Guest_Rhet Wylie_*

Guest_Rhet Wylie_*
  • Guests

Posted 29 August 2014 - 04:52 PM

Sorry for the confusion;  my reader was actually running at 115200 baud and I was not correctly encoding my output hex characters on the bus for configuring parameters.  

 

Referencing the arduino sample code here: setting the baud rate correctly works.  I especially like how the readers work on both rs-232/rs-485 transceivers at the same time.  Everything working great now, Thanks!



#4 Guest_Rhet Wylie_*

Guest_Rhet Wylie_*
  • Guests

Posted 29 August 2014 - 04:52 PM

Link left off earlier, but most people who look for it already know where it is:

 

http://learn.linkspr...ader-lsid-0702/



#5 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 01 September 2014 - 01:21 AM

Sorry for the confusion;  my reader was actually running at 115200 baud and I was not correctly encoding my output hex characters on the bus for configuring parameters.  

 

Referencing the arduino sample code here: setting the baud rate correctly works.  I especially like how the readers work on both rs-232/rs-485 transceivers at the same time.  Everything working great now, Thanks!

:)  About interfaces: RS485, RS232, Wiegand26, Wiegand34, RJ45(TCP/IP) or CANBUS

When order please specify which one as it only support one port at once. Default is RS232.



#6 Guest_Rhet Wylie_*

Guest_Rhet Wylie_*
  • Guests

Posted 03 September 2014 - 10:59 PM

That's interesting; I know the default I ordered was RS232 but the reader works out of the box on both RS485/RS232.



#7 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 04 September 2014 - 02:07 AM

That's interesting; I know the default I ordered was RS232 but the reader works out of the box on both RS485/RS232.

:o






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users