Jump to content


Photo

GPS Shield With SD Card Slot for Arduino V2.0 A


  • Please log in to reply
7 replies to this topic

#1 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 18 September 2014 - 01:00 AM

I can not receive GPS data. I used these instructions at http://learn.linkspr...gps-v2a-shield/ . Set TX->D2 and RX -> D3, SD Formatter


  • carpinteyrolkh, Adelinadulp, Afoesterces and 2 others like this

#2 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 18 September 2014 - 01:12 AM

Did the TinyGPS library  is unzip to your Arduino libraries?  And you compiled and upload the test_with_gps_device_LinkSpriteGPSV2A code to your Arduino successfully?

 

Then your jumpers is : TX->D2, RX -> D3.

 

Did you open the serial assistant at baud rate 9600?



#3 Guest_Albert Su_*

Guest_Albert Su_*
  • Guests

Posted 19 September 2014 - 12:58 PM

Yes, downloaded TinyGPS V13, used the test_with_gps_device_LinkSpriteV2A and uploaded code into library successfully and TX->D2, DX -> D3, and opened serial monitor for Adruino Uno. But get an error to check wiring. Do you have a sketch that I can upload that works?

#4 Guest_Albert Su_*

Guest_Albert Su_*
  • Guests

Posted 19 September 2014 - 01:00 PM

Yes, downloaded TinyGPS V13, used the test_with_gps_device_LinkSpriteV2A and uploaded code into library successfully and TX->D2, DX -> D3, and opened serial monitor for Adruino Uno. But get an error to check wiring. Do you have a sketch that I can upload that works?

#5 Guest_Albert Su_*

Guest_Albert Su_*
  • Guests

Posted 20 September 2014 - 08:09 AM

Link sprite GPS and SD V2.0A shield for Adruino Uno error appears "Please check wiring". Used the test_gps example sketch in soft serial V13 download and unplugged the shield from Arduino Uno during the upload, but still the same error and no GPS data. Can you recommend a workaround to solve this issue possibly caused trying to monitor the serial data from the USB?

#6 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 22 September 2014 - 01:26 AM

You can first try to use hardware serial of Arduino:

 

Set jumpers: TX--> MRX, RX---> MTX

 

void setup()
{
Serial.begin(9600);
}
void loop()
{
if (Serial.available() > 0)
{
Serial.print(char(Serial.read()));
}
}

 

Then use a serial assistant ( https://s3.amazonaws... GPRS/X_CTU.exe ) to check the serial data.



#7 Jimkan

Jimkan

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 June 2015 - 11:53 PM

Hello, just brought this shield and have the exact same problem as user GUEST_Albert reported, use X-CTU run com test/query modem but "Unable to communicate with modem"

 

Please help!!!



#8 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 03 July 2015 - 05:38 AM

Hello, just brought this shield and have the exact same problem as user GUEST_Albert reported, use X-CTU run com test/query modem but "Unable to communicate with modem"

 

Please help!!!

You can use another serial assistant to do the test, or just use the Serial Monitor of Arduino IDE.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users