Jump to content


CuHead v2.0 & Netgear Router


  • Please log in to reply
3 replies to this topic

#1 Guest_Steve_*

Guest_Steve_*
  • Guests

Posted 02 May 2014 - 04:25 AM

I have a LinkSprite CuHead V2.0 with an arduino duemilanove.  I downloaded the ZG2100 files from GitHub and am able to connect the shield to my phone hotspot with no problem, but I can't get it to connect to my Netgear Wndr3700v4 router using the same sketch and just changing the router SSID, gateway and IP address for the wifi unit in the sketch variables.  Both the phone and the router are set up to use identical WPA2-PSK security (same password). 

 

I've tried to turn off the security on the Netgear and set the security in the sketch to zero but no go with that as well.  I'm trying to connect to the 802.11a/b router SSID connection since I think the CuHead doesn't support n (different SSID on the router).

 

I've tried a couple of other variations of the libraries but all have the same behavior.  Is there anything else I can try to get this to work?

 

Thanks for any advice

 

 



#2 Guest_4583453624_*

Guest_4583453624_*
  • Guests

Posted 02 May 2014 - 04:58 AM

I also noticed that if I set the security in the sketch to 0 or 1, the red LED comes on, but if I set it to 2 or 3, it doesn't.  This is while trying to connect to the router.  In all cases I can't connect to the wifi unit or ping it though.  The LED turns off and back on periodically.

 



#3 Guest_SteveD_*

Guest_SteveD_*
  • Guests

Posted 04 May 2014 - 04:42 AM

Further playing, I booted up an old Dlink 614+ router and tried all security modes connecting to it, no dice either. 

 

Can anyone recommend a router that works with this board?  It's pretty bad that I may have to buy a new router just to get this to work :(



#4 chain

chain

    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 19 May 2014 - 01:45 AM

We use TP-LINK Wireless Router WR340G, the wifi shield works well.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users