Jump to content


Photo

eth0 - Device not ready on 11-10-14 sd image


  • Please log in to reply
14 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

I have the new image working but only via USB wireless - eth0 says "device not ready"



#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

I have the same problem. First none of the network adapters worked but after reflashing kernel the wlan started to work but eth0 still not working.



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

Go to Preferences > Network Settings. The wired tab should be first. Click Add. For me I change the connection name. Set it to connect automatically. Next click the Device Mac Address drop down and select the one that ends with (eth0). Click save.



#4 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

to Cwilt

Thanks, but did that several times with rebooting. no luck. Will try a reflash of the card...



#5 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

Did you disable the wireless networking? I think it will only connect to 1 at a time.



#6 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

I have tried a fresh download on a larger SD card and no Wifi with no luck -- I have turn off any wireless but no wired settings result is anything but device not ready
modify_inline.gif
 

 

 


#7 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

What are the messages in syslog related to this ?

My experience with Network Manager is not pleasant. For some people it works outside the box, for others it is always flaky. I blacklisted the wifi and eth0 from it and let it only configure the usb otg link.

NM ignores the interfaces defined in /etc/network/interfaces so you have to add the wifi there by hand. Then craft the wpa_Supplicant.conf (if needed, I can provide my samples).

So I wouln't trust the UI in this case but trying to configure the interface by hand in /etc/network/interfaces + the wpa_supplicant.conf file and with the help of syslog to figure out what goes on. My bet if that with NM out of the picture, things will be stable.



#8 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:28 AM

what model of pcDuino is this talking about?



#9 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

in my case it is a pcDuino3S



#10 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

I have pcDuino3 and these methods are not working for me either.



#11 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

I just put in a freshly made SD card and the first boot did not have network. I verified the network settings in network manager then powered down. Completely removed power and rebooted and networking was working as it should, wifi and wired.



#12 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

Did the same but no luck - what settings did you use before the reboot?
WiFi working just fine as this post is from pcDuino3s

ubuntu@ubuntu:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 02:0b:05:c1:45:74  
          inet6 addr: fe80::b:5ff:fec1:4574/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:258 (258.0 B)
          Interrupt:117 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:554 (554.0 B)  TX bytes:554 (554.0 B)

usb0      Link encap:Ethernet  HWaddr 00:11:22:33:44:55  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan6     Link encap:Ethernet  HWaddr 80:1f:02:b6:9b:b8  
          inet addr:10.0.0.28  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::821f:2ff:feb6:9bb8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:96 errors:0 dropped:250 overruns:0 frame:0
          TX packets:29 errors:0 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14620 (14.6 KB)  TX bytes:3404 (3.4 KB)

ubuntu@ubuntu:~$



#13 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

Just tried again and now Wifi is working and wired is "device not ready".

Hmmm.....



#14 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

Sorry to hear, but at least it is not me :-)

BTW I notice it usually indicates the link was available at the time of start up (as is x minutes ago) if that is any clue.

Rich



#15 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 03 December 2014 - 03:29 AM

I just noticed that net manager says not connected yet it is connected. Strangeness...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users