Jump to content


Photo

SPI link PcDuino3


  • Please log in to reply
5 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 18 December 2014 - 05:09 AM

I am trying to use the SPI link on the pcduino3 board. I have connected my 3 wires on J8(pin 4,5,6) and run the python code available on the following URL :

https://learn.sparkf...-communications

The result  printed on the screen is :

ubuntu@ubuntu:~$ cd SPI-Py/
ubuntu@ubuntu:~/SPI-Py$ sudo python setup.py install
running install
running build
running build_ext
running install_lib
running install_egg_info
Removing /usr/local/lib/python2.7/site-packages/SPI_Py-1.0-py2.7.egg-info
Writing /usr/local/lib/python2.7/site-packages/SPI_Py-1.0-py2.7.egg-info
ubuntu@ubuntu:~/SPI-Py$ python SPI.py
(0, 0, 0)

Can you explain me why i receive no information on why the SPI clk don't work.



#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 18 December 2014 - 05:09 AM

what kind of SPI device are you using?



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 18 December 2014 - 05:10 AM

I am using this board : "STEVAL-ISV009V1", you can show the features on the following URL :

http://www.st.com/we.../tools/PF251965



#4 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 18 December 2014 - 05:10 AM

As you can see, I need to send one "Command Word" and two "NOP" on the Mosi and after I will receive my data. Even if I changed this line : print spi.transfer((0x0B, 0x02, 0x00)) with the values I need, that change nothing.



#5 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 18 December 2014 - 05:10 AM

Can you tell me what connections you have between the SPI device and pcduino?



#6 alicechan11

alicechan11

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 30 January 2017 - 10:16 AM

 

I am trying to use the SPI link on the pcduino3 board. I have retractable banner stands connected my 3 wires on J8(pin 4,5,6) and run the python code available on the following URL :

https://learn.sparkf...-communications

The result  printed on the screen is :

ubuntu@ubuntu:~$ cd SPI-Py/
ubuntu@ubuntu:~/SPI-Py$ sudo python setup.py install
running install
running build
running build_ext
running install_lib
running install_egg_info
Removing /usr/local/lib/python2.7/site-packages/SPI_Py-1.0-py2.7.egg-info
Writing /usr/local/lib/python2.7/site-packages/SPI_Py-1.0-py2.7.egg-info
ubuntu@ubuntu:~/SPI-Py$ python SPI.py
(0, 0, 0)

Can you explain me why i receive no information on why the SPI clk don't work.

 

Thanks for the replies 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users