Jump to content


Photo

ERROR When updating packages


  • Please log in to reply
15 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 19 December 2014 - 08:32 PM

Hello, upon trying to update all the packages, I get the 

    Hit http://ports.ubuntu.com precise-updates/universe Translation-en
    Fetched 198 B in 27s (7 B/s)                         
    Reading package lists... Done
    W: GPG error: http://ports.ubuntu.com precise-security Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
    W: Conflicting distribution: http://www.wiimu.com pcduino Release (expected pcduino but got )
    root@ubuntu:/var/lib/apt#



Can someone help resolve?


  • carpinteyrolkh likes this

#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 19 December 2014 - 08:32 PM

Please just do sudo apt-get update.



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 19 December 2014 - 08:32 PM

Why does it still fail for www.wiimu.com
login as: root
root@192.168.0.120's password:
Welcome to Linaro 12.11 (GNU/Linux 3.4.29+ armv7l)

 * Documentation:  https://wiki.linaro.org/ ?
Last login: Fri Nov 28 21:52:16 2014 from 192.168.0.113
root@ubuntu:~# apt-get update
Hit http://ports.ubuntu.com precise Release.gpg
Hit http://ports.ubuntu.com precise-security Release.gpg
Hit http://ports.ubuntu.com precise-updates Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ports.ubuntu.com precise Release
Hit http://ports.ubuntu.com precise-security Release
Hit http://ppa.launchpad.net precise Release
Hit http://ports.ubuntu.com precise-updates Release
Hit http://ports.ubuntu.com precise/main Sources
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ports.ubuntu.com precise/universe Sources
Hit http://ports.ubuntu.com precise/main armhf Packages
Hit http://ports.ubuntu.com precise/universe armhf Packages
Hit http://ports.ubuntu.com precise/main TranslationIndex
Hit http://ports.ubuntu.com precise/universe TranslationIndex
Hit http://ports.ubuntu.com precise-security/main Sources
Hit http://ports.ubuntu.com precise-security/universe Sources
Hit http://ports.ubuntu.com precise-security/main armhf Packages
Hit http://ppa.launchpad.net precise/main armhf Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe armhf Packages
Hit http://ports.ubuntu.com precise-security/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe TranslationIndex
Hit http://ports.ubuntu.com precise/main Translation-en
Hit http://ports.ubuntu.com precise/universe Translation-en
Hit http://ports.ubuntu.com precise-security/main Translation-en
Hit http://ports.ubuntu.com precise-security/universe Translation-en
Hit http://ports.ubuntu.com precise-updates/main Sources
Hit http://ports.ubuntu.com precise-updates/universe Sources
Hit http://ports.ubuntu.com precise-updates/main armhf Packages
Hit http://ports.ubuntu.com precise-updates/universe armhf Packages
Hit http://ports.ubuntu.com precise-updates/main TranslationIndex
Hit http://ports.ubuntu.com precise-updates/universe TranslationIndex
Hit http://ports.ubuntu.com precise-updates/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://ports.ubuntu.com precise-updates/universe Translation-en
Hit http://www.wiimu.com pcduino Release.gpg
Hit http://www.wiimu.com pcduino Release
Hit http://www.wiimu.com pcduino/main Sources
Hit http://www.wiimu.com pcduino/main armhf Packages
Ign http://www.wiimu.com pcduino/main TranslationIndex
Ign http://www.wiimu.com pcduino/main Translation-en
Reading package lists... Done
W: Conflicting distribution: http://www.wiimu.com pcduino Release (expected pcduino but got )
root@ubuntu:~#
modify_inline.gif
 

 

 


#4 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 19 December 2014 - 08:32 PM

Same error here...  but wen I use:  apt-get upgrade instead of update works.   Of course, that does not update the package lists. 



#5 fsamir

fsamir

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 January 2015 - 04:37 AM

Still waiting for a fix for this issue.

The debian repository hosted at  wiimu.com is either unstable or broken for over a month.



#6 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 31 January 2015 - 01:05 AM

what are you waiting? I don;t think there is debian repository hosted at  wiimu.com.



#7 Tim

Tim

    Member

  • Members
  • PipPip
  • 25 posts

Posted 02 February 2015 - 05:15 AM

I "fixed" that by commenting the 2 lines that use wiimu.com in /etc/apt/sources.list.

 

I don't know if it's a very good solution, but at least I can update my system, and it seems like I can install any package I want, even without wiimu.



#8 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 02:37 AM

This is a good one.



#9 Chotokukyan

Chotokukyan

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 01 March 2015 - 12:55 AM

Was this issue resolved at all, or is Tim's solution a satisfactory fix?



#10 cwilt

cwilt

    Advanced Member

  • Members
  • PipPipPip
  • 1,012 posts

Posted 01 March 2015 - 01:21 AM

If you just can't stand seeing the error message then Tim's solution will work. I left it in and just ignore the error.



#11 avito

avito

    Member

  • Members
  • PipPip
  • 11 posts

Posted 04 November 2015 - 10:58 AM

I tried to update the arduino IDE and this error i still showing? Any help with fixing? 



#12 cwilt

cwilt

    Advanced Member

  • Members
  • PipPipPip
  • 1,012 posts

Posted 04 November 2015 - 12:14 PM

I don't believe a solution was ever found.



#13 Triqster

Triqster

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 19 November 2015 - 04:10 PM

So had a a similar issue. Went into /etc/apt/sources.list

 

Found the link in question: http://www.wiimu.com:8020/pcduino/- Tried view with web browser. As I have been trying on my work network, it seems blocked. 

 

Connected via a different internet source and it seems to be working. 

 

Recommendation: Check if you view the link in a web browser, if not, it might be just be a connectivity problem. For home networks - remember, you might have to open port 8020 on your router. Use www.canyouseeme.org to check if port 8020 is open.

 

Hope it helps!



#14 nightseas

nightseas

    Member

  • Administrators
  • 23 posts

Posted 30 November 2015 - 10:45 AM

Looks like the server is closed.

Just a lazy rabbit~~


#15 Duinorianer

Duinorianer

    Member

  • Members
  • PipPip
  • 13 posts

Posted 05 February 2016 - 02:53 PM

Is there any solution known, yet?

What would it mean that there are no package updates from wiimu?



#16 youkee

youkee

    Advanced Member

  • Administrators
  • 237 posts

Posted 27 May 2016 - 12:18 AM

We set up a new New packages repository for pcduino. Please modify /etc/apt/sources.list 

 

As to pcDuino8 Uno, add the following line:

 

 

As to pcDuino3/2/1, add the following lines:

 

 

 

After that, update system:

sudo apt-get update






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users