Jump to content


Problems installing WiFi Shield to Arduino UNO

  • Please log in to reply
3 replies to this topic

#1 renatodex



  • Members
  • Pip
  • 2 posts

Posted 29 January 2015 - 11:52 PM



I just acquired a WiFi shield V2.0, and i tried to install the Shield to my Arduino UNO. But im having some difficult.

First of all, i didnt found a consistent Manual for installing and testing this version of the shield.


About the lights, i noticed that there is a Green Led and a Red Led, in oposite sides of the board. What they means?


Also, i think maybe for transportation purposes, the board came without Pins attached to the board (they was appart).

When i tried to attach the board to my arduino, i have this felling that just attaching those pins to my Arduino UNO are not enough to make the connections.  (the green light keeps twitching when i softly move the Wifi shield)


Should i have to weld those pins to the WiFi board? (sorry for my noobish, i dont know nothing about welding)


I did all the tutorials, trying the Socket samples, Wifi server samples, and etc, but none of examples seems to work.


What bothers me is that the Shield IS connected, because i tested i simple circuit to light a LED using the Shield Pins, and it worked, but i still having difficult making the examples work.


I am doing somethign wrong?



#2 David


    Advanced Member

  • Administrators
  • 70 posts

Posted 30 January 2015 - 08:11 AM

Which WiFi shield? We have a few different WiFi shields.  

#3 renatodex



  • Members
  • Pip
  • 2 posts

Posted 30 January 2015 - 11:25 PM

This one:



#4 chain


    Advanced Member

  • Members
  • PipPipPip
  • 756 posts

Posted 09 February 2015 - 03:55 AM

It's need to weld the pin headers on the wifi shield.


The green LED is a indicator of charging Li-battery.

The red LED is a indicator for WiFi on.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users