Jump to content


Photo

Linksprite rover issues


  • Please log in to reply
6 replies to this topic

#1 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:10 AM

I installed Silicon Laboratories software to view the source files when the Linksprite Rover is connected to my pc. When connected I can see the icon from the image I attached. The issue is that when I click on the icon, nothing happens; because of this I can't view the files on the rover to trouble shoot the arduino software that controls movement of the rover.

The main issue is that the Rover connects wirelessly with control and viewing of the camera, but movement is corrupted; it only moves left indefinitely when you click left or right movement. There is no response with forward or backwards movement, or having control to turn on or off the led lights.  

How do I gain access to view and edit the source files of the rover if I can't gain access via usb to pc and if Silicon Laboratories is not allowing access?



#2 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:10 AM

I have access to the rover via cp210x usb to uart connection. I am using arduino IDE to upload the sketches, below are the settings I am using to interface with the rover:

Board: Arduino Diecimila or Duemilanove W/Atmea168

Serial Port: COM6

Programmer: AVRISP mkII

The sketch I am uploading is attached; when I verify and then upload I get the following error: 

avrdude: stk500_getsync(): not in sync: resp=0x00



#3 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:10 AM

Solution: avrdude stk500_getsync(): not in sync resp=0x30 error for Arduino
have had this error: I would plug my Arduino Uno into my Windows 7 PC (this guide should be relevant for Windows 8, Vista and XP also) but whenever I would upload any sketch to the board, all I would get is "avrdude stk500_getsync() not in sync resp=0x30" for a response. This board however worked seamlessly with my Linux machine.

After much searching online, I found there was no 'clear' solution to this.

Joyfully, the fix is actually very easy (at least for me, hopefully for you as well!). So far, there seems to be 2 big causes to this issue: you have the wrong COM port selected (the IDE does not see your board) and/or your Arduino drivers are not set properly.

Unlikely Cause: Bootloader is missing

Before we begin, we should check the bootloader of the Arduino for comprehension. If the bootloader is gone or corrupt, this can cause the issue.
To do this: power and reset the board. Check to see if the pin 13 built-in LED lights; if it is not then your bootloader may be missing. If this is the case, then your problem is beyond the scope of this guide. 

If the LED lights, then your bootloader still exists.

Cause #1: Wrong COM Port 

With the Arduino plugged to the computer, open "Device Manager" and check the "Ports". Check to see if an Arduino device is listed here; if it is, then make note of which COM port the Arduino is on and check that you have this selected in the Arduino IDE (Tools -> Serial Ports). If the COM port your board is on does not show within the IDE, then try different USB ports.

If you can't even see "Ports"; then for some reason, your computer isn't even recognizing that a device is plugged into it. Test your computer by plugging other USB devices into that port. Possibly your Arduino fails at life; try it with other computers.

Cause #2: Drivers not Installed

If you don't see an Arduino device listed under Ports; then you are probably seeing an "Unknown Device". Check to make sure that "Unknown Device" is indeed, the Arduino by plugging and unplugging the board from the computer. "Unknown Device" should appear and reappear. Assuming this is the case, you will need to install the drivers manually for your Arduino. Windows XP, Vista and 7 users may continue with the guide; if you are a Windows8 user, then please make reference to the comment left by finnigan16 below.

Right click on that "Unknown Device" and select "Properties". Click on the "Driver" Tab (Picture 2; Note: In my Picture 2, I already have the driver set, hence why my window reads "Arduino UNO R3 (COM4) Properties", when yours will probably read "Unknown Device Properties").

Select to "Update Driver..." and then choose to select the folder containing the driver on your computer. Conveniently, you already have the drivers for the Arduino on your computer when you installed the Arduino IDE. Navigate to within the Arduino files (where your .exe is; it'll probably be in your Downloads if you didn't move it. In the third picture, you can see my pathway to the drivers folder) to the "drivers" folder and choose the folder. The computer should automatically choose to install one of the drivers within the folder you selected. Simply proceed with the installation and that should fix the problem.

Make sure the Serial Port is then selected correctly!



#4 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:11 AM

 I just unplugged the USB from the PC (previously I had only unplugged it from the UNO. And pressed RESET on the board as well as restarted the IDE program. Not sure which one of those fixed the issue or if all of them did but I used the BLINK program as a test run and it's working fine now. Hope this helps anyone else who might be looking.

 

I have access to the rover via cp210x usb to uart connection. I am using arduino IDE to upload the sketches, below are the settings I am using to interface with the rover:

Board: Arduino Diecimila or Duemilanove W/Atmea168

Serial Port: COM6

Programmer: AVRISP mkII

The sketch I am uploading is attached; when I verify and then upload I get the following error: 

avrdude: stk500_getsync(): not in sync: resp=0x00


#5 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:11 AM

I just unplugged the USB from the PC (previously I had only unplugged it from the UNO. And pressed RESET on the board as well as restarted the IDE program. Not sure which one of those fixed the issue or if all of them did but I used the BLINK program as a test run and it's working fine now. Hope this helps anyone else who might be looking.


I have access to the rover via cp210x usb to uart connection. I am using arduino IDE to upload the sketches, below are the settings I am using to interface with the rover:

Board: Arduino Diecimila or Duemilanove W/Atmea168

Serial Port: COM6

Programmer: AVRISP mkII

The sketch I am uploading is attached; when I verify and then upload I get the following error: 

avrdude: stk500_getsync(): not in sync: resp=0x00
 
 

Your statement is a copy and paste from another forum and it does not address this specific linksprite rover build; the software is drivers for silicon labs usb to uart connection not for an arduino board. So I am still not able to access or upload files from the arduino IDE. 

This is very frustrating situation to believe this rover was ready to work out of the box, to only find that all parts, software, and boards are not compatible with each other.
modify_inline.gif
 
 


#6 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:11 AM

I am also getting this error:

avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x42

What board and programmer should be set under tools in the arduino IDE?



#7 cutedigi

cutedigi

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 12 February 2015 - 05:11 AM

This is the new message
Binary sketch size: 4,754 bytes (of a 14,336 byte maximum)
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x42
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51
 

I'm sorry to hear that.
As you know , I have never got this error message, and no experience how to fix it .but other people got this. So I gave their experience that could help you . and then you can try it .
you know , This problem is  also happened in the other arduino board  or arduino software (such as LiyPad, Mege, etc.)

I think "use -F" is important , it means Fix. but how to use it ?

Here are the things you could try :
1. switch computers: try xp, win7 32bit / 64 bit, win 8 32bit/64bit
2. switch USB cables: try new one.
3. uninstall/install drivers: uninstall using Device Manager, download drivers from FTDI website and install it
4. switch board: try new one.
5. restart the machine.
6. switch Serial ports.COM 7, 8 ,9 
7. swich baud: 115200, 9600

Anyone could help  dagoon79 ? please .



I am also getting this error:

avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x42

What board and programmer should be set under tools in the arduino IDE?
 
modify_inline.gif
 
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users