Jump to content


Photo

Updating kernel


  • Please log in to reply
3 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 12 February 2015 - 09:41 PM

I'd like to update to the latest stable Linux kernel, which appears to be: 3.16.1, way newer than the 3.4.29 that is on the PCDuino image. I found a guide that showed how to cross compile a kernel on a PC, but I don't see where to pick the version of the kernel in that guide. 
I want to compile ON the PCDuino, and from the kernel sources I downloaded from kernel.org. What's the trick to doing that?



#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 12 February 2015 - 09:41 PM

Well, I'm taking a stab at just doing it. Downloaded the kernel source, did a make menuconfig, selected the options that seemed relevant, and then I ran make.. We'll see if I get a usable kernel out of this. wink.gif



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 12 February 2015 - 09:41 PM

make[1]: `include/generated/mach-types.h' is up to date.
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  LINK    vmlinux
  LD      vmlinux.o
  MODPOST vmlinux.o
  GEN     .version
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  LD      init/built-in.o
drivers/built-in.o: In function `sunxi_gates_clk_setup':
devfreq.c:(.init.text+0x6a40): undefined reference to `reset_controller_register'
make: *** [vmlinux] Error 1

Drat, stopped cold in the kernel compile by that. I'll try changing some options in menuconfig and try the build again.



#4 scheik

scheik

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 17 October 2015 - 03:55 PM

Have you been succesfull to compile a newer kernel on pcDuino? Am interested in a newer Kernel than 3.4.79 which is used in the downloadable images.

 

Greets

fabian


  • LS-Support-12 likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users