Jump to content


Photo

adc0 problem


  • Please log in to reply
4 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 07:19 PM

Hello,

I try to compile with a pcduino on ArduinoIDE.
But every time I get the message : open /proc/adc0 failed
Do you know what it is?

Thank you
(And sorry for my english  tongue.gif)



#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 07:19 PM

Can you please try the code below, I suspect the ADC module is not loaded:
 

Code: [Select]

sudo modprobe adc



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 07:19 PM

Hello Viulian, 

thank you very much, it works!



#4 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 07:20 PM

Excellent smiley.gif

You can add it /etc/modules to always be loaded after you reboot the board. One line with adc on it.

Good luck.



#5 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 07:20 PM

Hello
Thank for your discussion. I solved my problem by entering sudo modprobe adc.

But now when I compile and upload the code. Nothing happen. A black window is opening and nothing happen. On my IDE I can always see "Uploading..."

Any idea to run that simple code

void setup() {
  // put your setup code here, to run once:
  Serial.begin(9600);

}

void loop() {
  // put your main code here, to run repeatedly: 
  Serial.println("Hello");
  
}

I am using pcDuino V2






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users