Jump to content


Photo

pcDuino3 XBMC black screen after random period of time


  • Please log in to reply
11 replies to this topic

#1 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:02 PM

Hello,

I'm hoping someone else has seen this issue and knows of a fix (or if it is even a common issue).  I use XBMC from time-to-time on my pcDuino3.  It works great using the Digitally Imported music add-on, etc...  The only problem I have is that the screen will go blank after a seemingly random interval and keyboard or mouse activity will not bring the display back.  This occurs regardless of if I have the screensaver (dim option) disabled or not.  XBMC is still active in the background as music is still playing and I can pause it, etc... using the keyboard.  The only way I can get the screen back is to press 's' on the keyboard and then 'enter' to exit XBMC and go back to the graphical desktop.  I've tested different cables and displays and get the same results.  The display/TV still 'thinks' it has a signal as I do not get the warning regarding 'no input' on the TV screen like I would if I powered the pcDuino3 off or unplugged the HDMI cable.  Unplugging and reconnecting the HDMI cable from the TV and back again doesn't 'kick start' it either.

Anyone have any ideas what may be causing this behavior?  I don't think it is a hardware issue since the video comes right back after exiting XBMC and relaunching the window manager (no reboot required).  I would think it is some config setting that I am missing or a file I need to edit to stop this.  In the meantime I've been using a Raspberry Pi running OpenELEC or Raspbmc for media duties, but would rather use the pcDuino if I can resolve this issue.

Thanks to anyone who may be able to point me in the right direction.



#2 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

I confirm this behavior. Requires a power reset to recover.



#3 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

Thanks Justin!  At least I know I'm not alone with this issue.  If I ever get it figured out or find an answer I will post back.



#4 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

Please describe in DETAIL Steps to Reproduce.
Let me do these Steps .
and then 
I'll report pcDuino engineers.

Thanks.



#5 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

This issue manifested itself when I was using either a 2.2A USB power supply, 3A battery pack or a 5A benchtop power supply. After a few minutes of working with XBMC, the HDMI output goes to a black screen. The only recovery option is a power reset. It does not seem to matter what activity is being performed in XBMC, watching video, adding files to libraries, etc. I am using the Ubuntu NAND image 07-21-2014. 



#6 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

To reproduce this all I have to do is boot the pcDuino3 (from NAND or from SD) and then launch XMBC.  From there it doesn't matter if you just let it sit there on the main screen or listen to music or watch video.  It did this with the original image and it also does this with the latest image as well.  Usually within 15 minutes of just leaving it there (without touching the keyboard or mouse) the screen will eventually go completely black and you cannot get the video back at all.  You can then only exit by pressing 's' on the keyboard and then 'enter' which exits back to the desktop.  Prior to discovering the keyboard shortcut to exit XBMC I would have to just hard reset like Justin.



#7 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

Thanks @Justin_M @ radu7.
I'll report this issue.



#8 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

And I confirm this behavior



#9 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:03 PM

Hey all!

It seems I've  the same problem with archlinux(using kernel 3.4.79+), can you try(in X11 session):

xset dpms force off

and see if you encountered same problem(black screen but not response when you move the move or press any keyboard key)



#10 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:04 PM

Hallo
Have the same Problem Hello
After updating to the current version of the Ubuntu from PCduino site.
Does anyone have an idea?



#11 jim

jim

    Advanced Member

  • Administrators
  • 3,385 posts

Posted 13 February 2015 - 09:04 PM

Hello. I can confirm this behavior with both ubunty and arch linux! What I have tried is boot up PcDuino with my TV that is connected to PcDuino. Then turn off TV and just let PcDuino run. Then turning on TV after a while (anything from couple of hours to 24 h) and TV can not detect any more signal/image from PcDuino. Hard reset or reboot thru ssh is necessary to get picture on the TV again.
Regards Nik



#12 nightwulfe

nightwulfe

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 22 December 2015 - 08:26 PM

I receive this behaviour, but only if I set the desktop manager to xbmc-standalone instead of lxde.

 

If I use lxde and then launch xbmc automatically via a .desktop file, I do not experience the issue.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users