Jump to content


Photo

How to start with a login shell in text mode


  • Please log in to reply
3 replies to this topic

#1 Galactic

Galactic

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 05 March 2015 - 08:27 PM

Hello,

I have a pcDuino v2, and in board-config, I have choose to start in text mode ( if I work with GUI/LXDE I run lightdm ). But when I turn power on, after boot, I am directly in root user account; I've not a login shell.

root@ubuntu:~#

And in this case, logout has no effect!!

What can I do in order to have a login shell in text mode.

Thanks.

 



#2 cwilt

cwilt

    Advanced Member

  • Members
  • PipPipPip
  • 1,012 posts

Posted 05 March 2015 - 09:57 PM

I think its either sudo ubuntu, or sudo linaro. Its been sometime since I used the login name for pcduino 1.

#3 Galactic

Galactic

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 March 2015 - 11:14 PM

Hi all,

 

After boot process, I would have something like this (it's my Linux/Slackware computer) :

Welcome to Linux 3.10.17 (tty1)
pc-asus login :

and not like that (actually on my pcDuino/Ubuntu) :

root@ubuntu~#:

or :

ubuntu@ubuntu~$:

It seem that at the end of boot process, "login process" is ignored and we go directly to the root account.



#4 76MPaul

76MPaul

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 August 2015 - 07:00 PM

Hi,

 

I was also facing the same issue and I found this : 

“to get rid of annoying root autologins rename “/etc/init/openvt.conf” to “/etc/init/openvt.conf.noboot” and edit “/etc/default/autogetty” to disable tty and serial autologin”

In a comment of this topic : https://www.the-grea...-u-boot-part-1/

It work well for me!

 

Hope it will help you if you haven't solved your issue yet!

 

Regards,

 

76MPaul


  • LS-Support-12 likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users