Jump to content


Photo

CuHead pro wifi /ethernet shield not responding as shown in example

CuHead wifi shield

  • Please log in to reply
4 replies to this topic

#1 Maxwell

Maxwell

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 January 2016 - 05:03 PM

I have the above shield mounted on an arduino uno. The music is streaming from my PC to the shield. However when I connect the shield to my wifi hub and type Hello world NOTHING happens.

 

I have followed your instructions, down loaded Sokit. Am using XCTU as well and it seems that when I run the code Goodnight Moon is being printed to the serial monitor as expectedbut Hello world does not appear in Sokit

 

The sketch is loaded on a PC, connected to the shield by UBS and connected to my wifi hub. The shield is also connected to the hub by accessing it via 10.10.10.254

 

Do I need to adjust some other parameters somewhere else.

 

Also this board id very poorly supported with code examples. I bought it as I wanted to get access to the internet. Can you point me to a example weather station that can be processed by this shield.

 

regards

Max



#2 youkee

youkee

    Advanced Member

  • Administrators
  • 237 posts

Posted 12 January 2016 - 02:09 AM

I'm not sure the Shield can receive music stream from PC, according to the introduction:

http://store.linkspr...lay-dlna-audio/

It said:

 

What is CuHead Pro WiFi/Ethernet Shield with AirPlay/DLNA Audino for Arduino? It is a WiFi Shield, it is an Ethernet Shield, it accepts audio pushed from iphone, iPad, Android phone or pad Wirelessly.



#3 Maxwell

Maxwell

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 12 January 2016 - 10:00 AM

Following on
I am not interested in the audio push aspect of this shield. I am interested in the UART to tcp communication
Basically I bought the shield to work with a Arduino uno for wireless communication.

I have read your example referred to above may times and the shield is not responding with hello world.
I have followed your instruction exactly. Is there something else I need to do like port forwarding or other that I need to do to get this to work
Also please show me where I can find code examples for this shield to undertake wireless operations
Regards
Max

#4 youkee

youkee

    Advanced Member

  • Administrators
  • 237 posts

Posted 14 January 2016 - 09:40 AM

Following on
I am not interested in the audio push aspect of this shield. I am interested in the UART to tcp communication
Basically I bought the shield to work with a Arduino uno for wireless communication.

I have read your example referred to above may times and the shield is not responding with hello world.
I have followed your instruction exactly. Is there something else I need to do like port forwarding or other that I need to do to get this to work
Also please show me where I can find code examples for this shield to undertake wireless operations
Regards
Max

 

Please download this firmware and update it:

https://s3.amazonaws...151107.20151107

 

 

 

TCP to UART Communication
 
The following work will be done on a PC.
First, we need to configure PC to connect to the AP of CuHead Pro. Please make sure that CuHead Pro is powered up and starts up properly.
 
Cuhead_pro_tcp_1.jpg
 
Open a web browser, and enter 10.10.10.254:, you will see firmware update. then select the new firmware and update it.
 

 

400px-Cuhead_pro_tcp_2.JPG


#5 Maxwell

Maxwell

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 14 January 2016 - 10:54 AM

Thank you for your reply

 

the firmware on my unit is wifiAudio 1.2.1537. please confirm that this is the latest version

 

I tried to downloaded the firmware as you suggested it never completed the process (it told me to wait a minute.....30 minutes later no result)

 

and when i selected to update via the internet online it replied that there were not any updates available

 

I have had this unit for over a week now and it is still not connected to the internet. Also you are not providing any code that shows me practically how to use this as a web server or client.

 

please give me a number to call you so we can resolve this problem (and other problems)

 

Max






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users