Jump to content


No ethernet or USB wifi


9 replies to this topic

#1 Guest_ted1951_*

Guest_ted1951_*
  • Guests

Posted 07 April 2016 - 12:30 AM

Greetings: I have a brand new pcDuino8. I have tried all the images, including android, on the downloads page and can't seem to get network communication. The tx rx leds show some activity at boot and then randomly flicker. Yes all my other wired and wifi devices work. What am I missing? A frustrated thanks.

#2 youkee

youkee

    Advanced Member

  • Administrators
  • 237 posts

Posted 13 April 2016 - 09:14 AM

Do you use pcDuino8 Uno or not? 

Which system image version do you use?

 

Have you uses ifconfig -a to check the Ethernet port?

 

Please send details.



#3 Guest_Mike Morrow_*

Guest_Mike Morrow_*
  • Guests

Posted 22 May 2016 - 07:52 PM

Different person, same problem.  ifconfig -a shows eth0 is there and has an IP address.  But /dev shows no eth0.  When I try to add it with the standard GUI, every tab is totally locked after I click Add.  Nothing shows, nothing works.  It's like it is there but the connection from the environment to the hardware is not happening.



#4 Guest_Pepepi_*

Guest_Pepepi_*
  • Guests

Posted 22 September 2016 - 04:00 AM

I have the same problem.
Is a any solution?



#5 Guest_panoflex_*

Guest_panoflex_*
  • Guests

Posted 29 September 2016 - 03:02 PM

i have just purchased a recommended by LINKSPRITE to attach a wifi dongle RT3750 or some shit it was 5 bucks shipped from china.  its in their documentation see if it matches up with your adapter the software we use on these boards is junk and only certain things work.  we will see if this adapter works or not i havent even bothered trying yet

 



#6 Guest_panoflex_*

Guest_panoflex_*
  • Guests

Posted 29 September 2016 - 04:20 PM

ok i can now show you how to get wifi working. 

 

1.first you will need this

https://www.amazon.c...0?ie=UTF8&psc=1

 

basically it is a wifi usb with Chipset Ralink: RT5370

 

2. then follow these steps

http://learn.linkspr...a-wifi-network/

 

everyhing i tried before failed but this works. 

 

as for the ethernet not working make sure it is setup properly for your network speed?  1gbits, 100mbits auto etc.  mine gave problems there.



#7 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 04 October 2016 - 01:53 AM

This is what I did on mine to get it working; note that in my case I'm assigning a static IP address and disabling network manager:

 

Edit /etc/resolv.conf, contents should be:

nameserver 192.168.1.1

 

Add this to the end of /etc/network/interfaces:


#The Primary Network Interface
auto eth0
iface eth0 inet static
address 192.168.1.200
network 192.168.1.0
netmask 255.255.255.0

gateway 192.168.1.1
dns-nameservers 192.168.1.1

 

 

create /etc/init/network-manager.override with the contents of:

manual

 

 

Then, reboot.



#8 thefoofighter

thefoofighter

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 23 November 2016 - 07:45 AM

Smily! you came to through for me twice today :) Those settings were perfect to get my ethernet adapter up and running for an SSH and VNC connection.

 

Do you perhaps know how i could share my Windows PC's internet connection with the board also? Internet comes to the PC through wifi, Ive tried a bridged connection and letting the board grab the settings automatically, ssh and all that worked but no internet, I also tried the sharing option on the wifi adapter by sharing the internet connection with my ethernet adapter but again no Internet, Not sure if its related to disabling the network manager?

 

Any pointers you have here would be majorly appreciated :)

 

Thank you



#9 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 20 December 2016 - 03:46 PM

Glad to help out!

 

Unfortunately, I'm not going to be much help with the Windows connection-sharing side; I just use Linux at home.

 

Since you can SSH to the board from the windows PC, but not connect to the internet from it, my gut-guess would be something up with the default gateway assigned to the board.

 

Some things you could test would be something along the lines of "traceroute yahoo.com" which should look something like --

root@whiteboard:~# traceroute yahoo.com
traceroute to yahoo.com (206.190.36.45), 30 hops max, 60 byte packets                                                         
 1  router.domain.com (192.168.1.1)  1.083 ms  1.181 ms  1.245 ms                                                       
 2  10.10.10.1 (10.10.10.1)  3.415 ms  3.611 ms  4.664 ms                                                                     
 3  10.47.11.1 (10.47.11.1)  12.312 ms  12.285 ms  12.223 ms                                                                  
 4  * * * 216.175.40.97 (216.175.40.97)  11.300 ms  11.206 ms  11.113 ms                                                
 6  199.116.81.25 (199.116.81.25)  531.941 ms  221.790 ms  223.222 ms                                                         
 7  xe-8-0-1.er2.ord7.us.zip.zayo.com (209.133.123.253)  13.949 ms  25.013 ms  20.948 ms
 8  ae11.er1.ord7.us.zip.zayo.com (64.125.21.217)  20.769 ms  20.680 ms  20.586 ms
 9  exchange-cust1.ch1.equinix.NET (206.223.119.16)  20.566 ms  20.499 ms  20.422 ms
10  ae-8.pat2.dnx.yahoo.com (216.115.96.121)  39.900 ms  39.791 ms  39.717 ms
11  ae-8.pat1.gqb.yahoo.com (216.115.96.122)  61.111 ms ae-6.pat2.gqb.yahoo.com (216.115.96.62)  60.726 ms  60.647 ms
12  et-1-0-0.msr1.gq1.yahoo.com (66.196.67.101)  59.980 ms et-18-1-0.msr1.gq1.yahoo.com (66.196.67.103)  60.365 ms et-19-1-0.msr2.gq1.yahoo.com (66.196.67.111)  60.574 ms
13  et-1-1-0.clr2-a-gdc.gq1.yahoo.com (67.195.37.75)  59.016 ms et-19-1-0.clr2-a-gdc.gq1.yahoo.com (67.195.37.99)  59.528 ms et-1-0-0.clr1-a-gdc.gq1.yahoo.com (67.195.37.93)  59.476 ms
14  et-17-25.fab2-1-gdc.gq1.yahoo.com (67.195.1.79)  59.454 ms UNKNOWN-67-195-1-X.yahoo.com (67.195.1.247)  64.045 ms et-18-1.fab1-1-gdc.gq1.yahoo.com (67.195.1.89)  62.402 ms
15  po-9.bas1-7-prd.gq1.yahoo.com (206.190.32.13)  61.692 ms po-12.bas2-7-prd.gq1.yahoo.com (206.190.32.35)  62.334 ms po-13.bas2-7-prd.gq1.yahoo.com (206.190.32.37)  62.318 ms

(You may have to do "apt-get install traceroute" (no quotes) before you can do so however.)

 

Or if that doesn't work, you could try to traceroute to Google's public DNS servers (8.8.8.8 or 8.8.4.4) and see if they resolve.

 

If it's not making it outside of your home network, it's probably something default-gateway or firewall related.



#10 thefoofighter

thefoofighter

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 22 December 2016 - 07:58 PM

For those who might be interested it was easier than i originally thought.

  • Make sure your PC is connected to wifi and that your pcduino is connect through the PC's ethernet jack (should work also if your pc gets internet from a usb device)
  • Go to your Wifi adapters properties and select sharing, Share internet with the ethernet adapter that is connected to the pcduino
  • Then on the pcduino set your /etc/network/interfaces

to look like this,


auto eth0
iface eth0 inet dhcp

The pcduino will then grab the appropriate ip and gateway automatically as windows will set the adapter up for you.

 

Thanks again Smily for your help, it got me going in the right direction.





Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users