Jump to content


Photo

7 inch screen driver installation issue


  • Please log in to reply
1 reply to this topic

#1 SudoPenguin

SudoPenguin

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 20 October 2016 - 01:38 PM

hello the group and thanks for your time :)

i'm rather new to Ubuntu.  i bought  a pcduino and a 7" lvds on the premise that it would work out of the box maybe the salesman meant it would out of the box with a hdmi  monitor or tv perhaps but it don't work with the little screen out of the box.  anyway been learning bit by bit. i have the cables between the screen and the pcduino hooked up but i seem to have a problem installing the driver i followed a video on the net i found and i can find the driver file on my system however when i try to  sudo insmod ft5x_ts.ko i get nothing just the following message

 

 

ubuntu@ubuntu:~$ ls
Arduino  Documents  Music     Public     Videos  modules
Desktop  Downloads  Pictures  Templates  help    sample
ubuntu@ubuntu:~$ cd modules
ubuntu@ubuntu:~/modules$ ls
README.md  pcduino-ir-keypad  pcduino-pwm-sysfs  regtool  sun4i-cpu-id  touch
ubuntu@ubuntu:~/modules$ cd touch
ubuntu@ubuntu:~/modules/touch$ ls
Makefile  build.sh  ft5x  gsl  init-input.h
ubuntu@ubuntu:~/modules/touch$ cdft5x
bash: cdft5x: command not found
ubuntu@ubuntu:~/modules/touch$ cd ft5x
ubuntu@ubuntu:~/modules/touch/ft5x$ ls
Makefile         ft5x02_config.h      ft5x_ts.ko  ini.h
ft5x.c           ft5x02_ini_config.h  ft_app.i    oflim-V31_20130909_app.h
ft5x02_config.c  ft5x_ts.h            ini.c
ubuntu@ubuntu:~/modules/touch/ft5x$ sudo insmod ft5x_ts.ko 
insmod: error inserting 'ft5x_ts.ko': -1 File exists
ubuntu@ubuntu:~/modules/touch/ft5x$
i have tried variations of sudo and insmod but  no joy any thought as to what i am doing wrong ?
 


#2 Reefwing

Reefwing

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 July 2017 - 07:45 AM

I had the same problem - you can read the different things I tried at: https://reefwingrobo...uch-screen.html

 

I can't get it to work.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users