Jump to content


Photo

Boinc Only Using 4 Cores - Convert install to headless


5 replies to this topic

#1 metuckness

metuckness

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 25 December 2016 - 07:30 PM

Hi,

 

I purchased this pcDuino to use to crunch Boinc Project under the assumption that the device ran Ubuntu, which is does but I didn't research it to realize it was a specific version designed for the unit. Anyway, I was able to get the latest image installed and running and even got the Boinc Client installed, but it is only reporting as a 4 core CPU instead of 8 and while Boinc lists 8 cores, it puts 4 of them into some sort of status and only runs with 4 of the cores.

 

My first question is, anyone setup Boinc on one of these and have instructions of getting all 8 cores to process work units at the same time? That is why I got it in the first place.

 

The second question I got is kinda a multi question. Now that it is installed, what is the default root password and is there another user that it uses to login by default? Sorry, I am not a Linux guru, kinda teaching myself by tossing myself into the fire and a lot of Googling, forum posts. The other parts of the question is, now that I got it connected to the internet and fixed all the Namesever issues (working on the static IP next and I want to get wireless working as well) and I can SSH into the unit, how do I make it headless and get rid of the Xorg running and have it boot up to a prompt and not load Xorg?

 

I appreciate the help! I attached two images, one of the TOP showing resources running, Xorg I believe is the desktop and the other is of Boinctui which shows information on Bounc and you can see it has four cores in a wait state, which I have never seen before. Sorry second image is kinda blurry had to try and fit it into the post since they only allow 500kb of combined uploads, will post a second followup with higher resolution (guess not).

 

Mitch

Attached Thumbnails

  • pcduino8-1.jpg
  • pcduino8-2a.jpg


#2 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 27 December 2016 - 01:28 AM

Hi!
For the root password change, just sign in as linaro/linaro and theb do "sudo su" ( o quotes) then "passwd" (no quotes) to change it. You should do this for the linaro user as well.

#3 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 27 December 2016 - 01:32 AM

Check out my post here for getting rid of all of the X stuff: http://forum.linkspr...st_return=12726

#4 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 27 December 2016 - 01:33 AM

I haven't messed with the udev stuff in a few months though, so be aware that it could cause issues.

#5 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 27 December 2016 - 01:42 AM

Also, if you're planning on using all 8 cores for any length of time at once, you might want to consider powering the board from the power in pins on the board itself, rather than the micro USB port. On the picture that I'm attaching, they are the lower 2 wires on the left hand side.

#6 metuckness

metuckness

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 28 December 2016 - 07:05 PM

Also, if you're planning on using all 8 cores for any length of time at once, you might want to consider powering the board from the power in pins on the board itself, rather than the micro USB port. On the picture that I'm attaching, they are the lower 2 wires on the left hand side.

Thanks for the other info. I did find your post on removing X and did it.

 

Can you post that picture for powering the board via the pins? I have tried everything to get the unit to use all 8 cores and it constantly falls back to 4 cores only. So if there is a way I can power the board to use all 8 cores please let me know!

 

Oh and let me know how much voltage I can send to it. I read a post that said no more than 5V, if that is the case, what difference does it make if it comes from the USB or the pins as they are both 5v?

 

Thank you!





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users