Jump to content


Photo

Why does USB repeat connecting and disconnecting?

USB

1 reply to this topic

#1 kns5498

kns5498

    Member

  • Members
  • PipPip
  • 26 posts

Posted 27 December 2016 - 08:43 AM

 

Jan  1 10:01:18 linaro-alip kernel: [   74.351627] hub 1-1:1.0: port 4 disabled by hub (EMI?), re-enabling...

Jan  1 10:01:18 linaro-alip kernel: [   74.359134] usb 1-1.4: USB disconnect, device number 4
Jan  1 10:01:18 linaro-alip kernel: [   74.880256] usb 1-1.4: new low-speed USB device number 5 using sunxi-ehci
Jan  1 10:01:18 linaro-alip kernel: [   75.018875] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0001
Jan  1 10:01:18 linaro-alip kernel: [   75.018894] usb 1-1.4: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Jan  1 10:01:18 linaro-alip kernel: [   75.018906] usb 1-1.4: Manufacturer: eGalax Inc.
Jan  1 10:06:22 linaro-alip kernel: [  378.223629] hub 1-1:1.0: port 4 disabled by hub (EMI?), re-enabling...
Jan  1 10:06:22 linaro-alip kernel: [  378.231214] usb 1-1.4: USB disconnect, device number 5
Jan  1 10:06:22 linaro-alip kernel: [  378.800388] usb 1-1.4: new low-speed USB device number 6 using sunxi-ehci
Jan  1 10:06:22 linaro-alip kernel: [  378.939149] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0001
Jan  1 10:06:22 linaro-alip kernel: [  378.939170] usb 1-1.4: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Jan  1 10:06:22 linaro-alip kernel: [  378.939184] usb 1-1.4: Manufacturer: eGalax Inc.
Jan  1 10:07:07 linaro-alip kernel: [  423.791761] hub 1-1:1.0: port 4 disabled by hub (EMI?), re-enabling...
Jan  1 10:07:07 linaro-alip kernel: [  423.799298] usb 1-1.4: USB disconnect, device number 6
Jan  1 10:07:08 linaro-alip kernel: [  424.450290] usb 1-1.4: new low-speed USB device number 7 using sunxi-ehci
Jan  1 10:07:08 linaro-alip kernel: [  424.588888] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0001
Jan  1 10:07:08 linaro-alip kernel: [  424.588912] usb 1-1.4: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Jan  1 10:07:08 linaro-alip kernel: [  424.588927] usb 1-1.4: Manufacturer: eGalax Inc.
Jan  1 10:07:14 linaro-alip kernel: [  430.703878] hub 1-1:1.0: port 4 disabled by hub (EMI?), re-enabling...
Jan  1 10:07:14 linaro-alip kernel: [  430.711546] usb 1-1.4: USB disconnect, device number 7
(syncopation)
Jan  1 12:05:52 linaro-alip kernel: [ 7548.313082] ehci_irq: highspeed device disconnect
Jan  1 12:05:52 linaro-alip kernel: [ 7548.313218] usb 1-1: USB disconnect, device number 117
Jan  1 12:05:52 linaro-alip kernel: [ 7548.313237] usb 1-1.2: USB disconnect, device number 118
Jan  1 12:05:52 linaro-alip kernel: [ 7548.316095] ehci_irq: highspeed device connect
Jan  1 12:05:52 linaro-alip kernel: [ 7548.531957] usb 1-1.4: USB disconnect, device number 119
Jan  1 12:05:53 linaro-alip kernel: [ 7549.310165] usb 1-1: new high-speed USB device number 120 using sunxi-ehci
Jan  1 12:05:53 linaro-alip kernel: [ 7549.461034] usb 1-1: New USB device found, idVendor=1a40, idProduct=0101
Jan  1 12:05:53 linaro-alip kernel: [ 7549.461063] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Jan  1 12:05:53 linaro-alip kernel: [ 7549.461081] usb 1-1: Product: USB 2.0 Hub
Jan  1 12:05:53 linaro-alip kernel: [ 7549.462104] hub 1-1:1.0: USB hub found
Jan  1 12:05:53 linaro-alip kernel: [ 7549.462271] hub 1-1:1.0: 4 ports detected
Jan  1 12:05:53 linaro-alip kernel: [ 7549.740363] usb 1-1.2: new high-speed USB device number 121 using sunxi-ehci
Jan  1 12:05:53 linaro-alip kernel: [ 7549.923397] usb 1-1.2: New USB device found, idVendor=05a3, idProduct=9230
Jan  1 12:05:53 linaro-alip kernel: [ 7549.923424] usb 1-1.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Jan  1 12:05:53 linaro-alip kernel: [ 7549.923442] usb 1-1.2: Product: USB 2.0 Camera
Jan  1 12:05:53 linaro-alip kernel: [ 7549.923456] usb 1-1.2: Manufacturer: HD Camera Manufacturer
Jan  1 12:05:53 linaro-alip kernel: [ 7549.927886] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (05a3:9230)
Jan  1 12:05:53 linaro-alip kernel: [ 7549.968680] is_otg_flag: 0x0,
Jan  1 12:05:53 linaro-alip kernel: [ 7550.070290] usb 1-1.4: new low-speed USB device number 122 using sunxi-ehci
Jan  1 12:05:54 linaro-alip kernel: [ 7550.208901] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0001
Jan  1 12:05:54 linaro-alip kernel: [ 7550.208927] usb 1-1.4: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Jan  1 12:05:54 linaro-alip kernel: [ 7550.208956] usb 1-1.4: Manufacturer: eGalax Inc.
Jan  1 12:06:18 linaro-alip kernel: [ 7574.654581] ehci_irq: highspeed device disconnect
Jan  1 12:06:18 linaro-alip kernel: [ 7574.654725] usb 1-1: USB disconnect, device number 120
Jan  1 12:06:18 linaro-alip kernel: [ 7574.654744] usb 1-1.2: USB disconnect, device number 121
Jan  1 12:06:18 linaro-alip kernel: [ 7574.657603] ehci_irq: highspeed device connect
Jan  1 12:06:18 linaro-alip kernel: [ 7574.902007] usb 1-1.4: USB disconnect, device number 122
Jan  1 12:06:19 linaro-alip kernel: [ 7575.590194] usb 1-1: new high-speed USB device number 123 using sunxi-ehci
Jan  1 12:06:19 linaro-alip kernel: [ 7575.741174] usb 1-1: New USB device found, idVendor=1a40, idProduct=0101
Jan  1 12:06:19 linaro-alip kernel: [ 7575.741205] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Jan  1 12:06:19 linaro-alip kernel: [ 7575.741225] usb 1-1: Product: USB 2.0 Hub
Jan  1 12:06:19 linaro-alip kernel: [ 7575.742442] hub 1-1:1.0: USB hub found
Jan  1 12:06:19 linaro-alip kernel: [ 7575.742670] hub 1-1:1.0: 4 ports detected
Jan  1 12:06:19 linaro-alip kernel: [ 7576.020403] usb 1-1.2: new high-speed USB device number 124 using sunxi-ehci
Jan  1 12:06:20 linaro-alip kernel: [ 7576.203296] usb 1-1.2: New USB device found, idVendor=05a3, idProduct=9230
Jan  1 12:06:20 linaro-alip kernel: [ 7576.203326] usb 1-1.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Jan  1 12:06:20 linaro-alip kernel: [ 7576.203346] usb 1-1.2: Product: USB 2.0 Camera
Jan  1 12:06:20 linaro-alip kernel: [ 7576.203362] usb 1-1.2: Manufacturer: HD Camera Manufacturer
Jan  1 12:06:20 linaro-alip kernel: [ 7576.207693] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (05a3:9230)
Jan  1 12:06:20 linaro-alip kernel: [ 7576.248522] is_otg_flag: 0x0,
Jan  1 12:06:20 linaro-alip kernel: [ 7576.350357] usb 1-1.4: new low-speed USB device number 125 using sunxi-ehci
Jan  1 12:06:20 linaro-alip kernel: [ 7576.498906] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0001
Jan  1 12:06:20 linaro-alip kernel: [ 7576.498936] usb 1-1.4: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Jan  1 12:06:20 linaro-alip kernel: [ 7576.498967] usb 1-1.4: Manufacturer: eGalax Inc.

Attached File  kern.txt   175.06KB   129 downloads

 

At first, it seems that there is a problem of disconnecting only the touch panel.

As time goes by, the USB hub will also have problems.

(The USB hub is connected to the touch panel and USB camera.)

 

What causes it and there is no way to solve it?



#2 smily03

smily03

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts

Posted 28 December 2016 - 05:10 PM

Out of curiosity, are you powering the hub and panel from the USB port on the board? Or do they have extra power supplies? Also, have you tried different USB cables, bypassing the USB hub, and all that fun stuff?



Reply to this topic



  



Also tagged with one or more of these keywords: USB

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users