Jump to content


Photo

Is it possible that i have burned the serial debug port?

serial debug

  • Please log in to reply
No replies to this topic

#1 whyme456

whyme456

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 13 January 2017 - 03:32 AM

I've had a pcDuino3 for a couple of years now but i haven't worked on it lately.

 

I booted it up successfully, but as i remember the serial debug port was really useful to configure the pcduino3 without connecting it to my network or to my computer using OTG.

 

A mistake was made while connecting the serial pins to an FTDI serial to usb converter, first i left it on the 5v mode, and i also plugged the pins all in the wrong order, even the ground one.

 

I have two FTDI adapters and they are both working when i connect them to each other, so i tried the serial communication @115200 with the pcDuino but i cant get the pcduino to talk back, there is zero response when i connect it to the serial adapter even when the tx led on the pcduino is blinking.

 

When i unplug the ground pin of the FTDI the computer reads random characters, when i plug it back, nothing. Now im sure it's connected the right way, and i've even tried to invert the tx and rx jumper cables.

 

I have broken those pins haven't i?

 

Is there any way to fix them?

 

I've tried burning again the kernel and installing ubuntu again, but it still doesn't work.

 

Is there any hardware/software fuse i might have triggered? What options do i have?

 

Thanks in advance!

 







Also tagged with one or more of these keywords: serial debug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users