Jump to content


PHY going UP and DOWN


1 reply to this topic

#1 Guest_Kosmik_*

Guest_Kosmik_*
  • Guests

Posted 10 March 2017 - 10:20 AM

I have finally succeded in a working DVB-T USB stick with pcDuino8 UNO. I have used gstream to stream the channels to local network. But the streaming is unstable. Looking in dmesg i have found out that the obvious problem is the unstable phy (gmac) which quite often resets the ethernet connection. Example from dmesg:

 

[37693.870127] PHY: gmac0-0:00 - Link is Down
[37694.870115] PHY: gmac0-0:00 - Link is Up - 1000/Full
[38756.890344] PHY: gmac0-0:00 - Link is Up - 100/Full
 

Internet searching provided me with some issues on similar boards with the RTL8211E chip suggesting some tweaking with tx delay setting ( http://linux-sunxi.org/Ethernet). Yet I did not find a way how apply this tweak - putting it in config file during kernel compilation did not end with any improvement. I am not sure, if this issue is the case, maybe it is originated somewhere else (e.g. power saving options). I tried two ethernet "sources (NETIS router and TP-LINK switch) three different cables, 5 different power supplies, but nothing helped. Is there someone who can suggest what else can be tried to make the ethernet connection more stable?



#2 Guest_Kosmik_*

Guest_Kosmik_*
  • Guests

Posted 10 April 2017 - 08:01 AM

Last week I found a workaround. It is not en external USB-ethernet adapteur (as someone might expect) as it reaches painfully low transmit speeds (btw. - is the USB port really 2.0?). Before compilation of new kernel, I exchanged the gmac related source files (sunxi_geth.h sunxi_geth.c sunxi_libgeth ; actually all differing files in the /linux-3,4/drivers/net/ethernet/sunxi/eth folder) by the files from the kernel source for Orange pi zero board ( http://www.orangepi....nloadresources/). With this kernel and when connected to a 100 Mbs router/switch, the ethernet link is stable (no phy going down or changing speed for four days at the time of writing) - which is a great improvement! Unfortunatelly when connected to a Gbs router, I am not able to ping the pcDuino at all (even though the port led is blinking and dmesg claims that it is connected at 1000 Mbs). Perhaps when the differing parts of the gmac source files will be analyzed in more details, the problematic code might be identified and corrected. So far, I am happy with the stable 100 Mbs connection!





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users