Jump to content
Sign in to follow this  

GPS SD Shield for Arduino Never receives sat signal

Recommended Posts

I recently purchased a new GPS SD Shield for Arduino on eBay and have tried several sketches to get it to work.  I have let it run for 30+ minutes and it never receives a signal.  I saw the post here:http://linksprite.com/wiki/index.php5?title=GPS_Shield_with_SD_card_slot_for_Arduino_V3.0_with_external_GPS_antenna and was confused.  It shows the removal of the atmega328P chip.  Why remove it??  I have an Arduino Uno R3.  I'm using a GPS antenna that states Frequency: 1575 Mhz, 3V-5V.

I've tried multiple sketches (all using the TinyGPS library) and none work.

UPDATE: I've used the X-CTU serial monitor app and confirmed that I am receiving GPS data after all!  The problem seems to be in the TinyGPS library.  Do you, the manufacturer, suggest any specific Arduino library that I should use?  How do I capture the streaming GPS NMEA strings in my custom app running on the Arduino??

Share this post

Link to post
Share on other sites

I've got the logger working now!  In case anyone else was having the same issue, this is what I wound up doing.

Initially, I connected the shield to my Arduino Uno and uploaded the test_with_gps_device sketch that came with the TinyGPS library.  All I saw in the serial monitor was the header lines then rows and rows of *'s.I tried different Rx & Tx settings but never got a response other than *'s.

I put the gps shirld in a drawer for almost two months and then decided to try working with it again.  I found a link to the wiki in my original post that showed the Arduino with the ATMega chip removed.  Not very useful if I wanted to write my own app to work with the shield.  I decided to upload a completely empty sketch consisting of an empty setup() and loop() subs.  Once I did that, I saw the NMEA text in the X-CTU serial terminal app!!  I checked the lat & long manually and sure enough, it was my location! 

At least I knew it worked!  A couple hours later and the test_with_gps_device sketch started working!  I had to set the UART Multiplexer jumpers to Tx=3 and Rx = 2.  Anything other than 1 & 0 because those are the pins the Arduino use for it's Serial() communication.  Then I set the SoftwareSerial pins to match the 3, 2 of the jumpers.  Oh, and i had to set the SoftwareSerial speed to 9600 because that's the speed the X-CTU app was using when I saw its output. 

My problem was in fully understanding the role of the Dx (digital) & Ax(analog) pins worked.  After it "clicked" that the SoftwareSerial was reading the data that the gps shield was now transmitting on those pins, it made sense.

Oh well, this is pretty verbose but it may help the next guy!


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this