Jump to content
Sign in to follow this  
chain

Wifi Connectection

Recommended Posts

I need help in how to connect the cuhead wifi shield v2 to WIFI. I plugged it on the Arduino Uno R3 and currently it lights up green. I followed many tutorialsin how todo by

1. Insert Cuhead Libary
2. Open simpleSever
3. Input IP settings

This has not worked for me, as the red light did not light up.
I am very fustratated, i have tried other ways for the past 3 days. Please can you help. Thanks. 

Share this post


Link to post
Share on other sites

apologies on late reply.

I have tried the following and still no luck. Do you mean to use my phone as a personal hotspot and if so how?

i am creating a gas detector alarm using the arduino microcontoller. I need wifi connectivity to this project so that once the alarm is triggered it will send a warning to the user. 

The deadline for this project is 09/05/2014.Please can you help i dont have much time.

Share this post


Link to post
Share on other sites

Out of desperation I'm going to post my own setup here, I've gotten the CuHead 2.0 to work with my phone hotspot with no issue, but it refuses to connect with my NetGear WNDR3700 and Dlink 614+. I don't get a red LED. The router is set up on 192.168.1.1, with WPA2-PSK, and the SSID VDI on the 2.4GHz channel.


// Wireless configuration parameters ----------------------------------------
unsigned char local_ip[] = {192,168,1,29}; // IP address of WiShield
unsigned char gateway_ip[] = {192,168,1,1}; // router or gateway IP address
unsigned char subnet_mask[] = {255,255,255,0}; // subnet mask for the local network
const prog_char ssid[] PROGMEM = {"VDI"}; // max 32 bytes

unsigned char security_type = 3; // 0 - open; 1 - WEP; 2 - WPA; 3 - WPA2

// WPA/WPA2 passphrase
const prog_char security_passphrase[] PROGMEM = {"8708814xxx"}; // max 64 characters


If anyone can give clues as to why it doesn't work I would be eternally grateful.

Thanks
 

Share this post


Link to post
Share on other sites

As your describe , I think its the router's problem. You can try to reset your router, and try again.

 

We use TP-LINK Wireless Router WR340G, the wifi shield works well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×