Jump to content
Sign in to follow this  
jim

pcDuino 3s: input/output error

Recommended Posts

Worked fine for a couple of days. After a reset without shutting down, the following started happening when rebooted.


/dev/nandd checks out as clean.
mounts in ordered data mode

Then this:
init: plymouth main process (76) terminated with status 127
init: ureadahead main process (78) terminated with status 5
/proc/self/fd/9: 28: /proc/self/fd/9: /etc/init.d/rcS: input/output error

and there it sits.

pcDuino3S.
fsck on disk shows clean.
attempting to run /etc/init.d/rcS ends with "I/O error"

1. Will re-flashing the device work?
2. Does re-flashing using a 2-ended male USB cable?
3. Do instructions regarding the pcDuino3 apply as well to the pcDuino3S? For example, can I install a microUSB card internally to increase internal storage?



I have tried reflashing the kernel and the image. The instructions provided on your website apply to the pcDuino3, and not to the pcDuino3s, and I've had no success.
1. There is no slot on the board for a microSD card. The microSD connector on the 3S is for power.
2. There is no obvious way to set the device into ADB mode.
3. Using a USB cable to the 3s doesn't work using PhoenixSuit.

Share this post


Link to post
Share on other sites

Hi,

I had the same issue trying to flash the pcduino3s. I followed the intructions jim sends, using the USB OTG port, but there is no way of booting the device in "upgrade mode". Should the pcduino 3s be recognized in PhoenixSuit?, because the only thing I get is "No device attached yet".

anyone was able to flash pcduino 3s? :/, are there any pcduino 3s specific instructions?.


EDIT: ( now I think, maybe this post should be moved to a proper category, pcduino3s/flashing )

Share this post


Link to post
Share on other sites

great!. I'll try that.

Another question. What's the difference of upgrading the packages from the repos with "apt-get upgrade", and flashing the device?. If I understand well, I need to flash the device just to update de kernel, right?. But for all the other packages, like XBMC, should be enought to update with apt?.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×