Jump to content
jim

ERROR When updating packages

Recommended Posts

Hello, upon trying to update all the packages, I get the 

    Hit http://ports.ubuntu.com precise-updates/universe Translation-en
    Fetched 198 B in 27s (7 B/s)                         
    Reading package lists... Done
    W: GPG error: http://ports.ubuntu.com precise-security Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key ftpmaster@ubuntu.com>
    W: Conflicting distribution: http://www.wiimu.com pcduino Release (expected pcduino but got )
    root@ubuntu:/var/lib/apt#



Can someone help resolve?

Share this post


Link to post
Share on other sites
Why does it still fail for www.wiimu.com
login as: root
root@192.168.0.120's password:
Welcome to Linaro 12.11 (GNU/Linux 3.4.29+ armv7l)

 * Documentation:  https://wiki.linaro.org/ ?
Last login: Fri Nov 28 21:52:16 2014 from 192.168.0.113
root@ubuntu:~# apt-get update
Hit http://ports.ubuntu.com precise Release.gpg
Hit http://ports.ubuntu.com precise-security Release.gpg
Hit http://ports.ubuntu.com precise-updates Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ports.ubuntu.com precise Release
Hit http://ports.ubuntu.com precise-security Release
Hit http://ppa.launchpad.net precise Release
Hit http://ports.ubuntu.com precise-updates Release
Hit http://ports.ubuntu.com precise/main Sources
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ports.ubuntu.com precise/universe Sources
Hit http://ports.ubuntu.com precise/main armhf Packages
Hit http://ports.ubuntu.com precise/universe armhf Packages
Hit http://ports.ubuntu.com precise/main TranslationIndex
Hit http://ports.ubuntu.com precise/universe TranslationIndex
Hit http://ports.ubuntu.com precise-security/main Sources
Hit http://ports.ubuntu.com precise-security/universe Sources
Hit http://ports.ubuntu.com precise-security/main armhf Packages
Hit http://ppa.launchpad.net precise/main armhf Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe armhf Packages
Hit http://ports.ubuntu.com precise-security/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe TranslationIndex
Hit http://ports.ubuntu.com precise/main Translation-en
Hit http://ports.ubuntu.com precise/universe Translation-en
Hit http://ports.ubuntu.com precise-security/main Translation-en
Hit http://ports.ubuntu.com precise-security/universe Translation-en
Hit http://ports.ubuntu.com precise-updates/main Sources
Hit http://ports.ubuntu.com precise-updates/universe Sources
Hit http://ports.ubuntu.com precise-updates/main armhf Packages
Hit http://ports.ubuntu.com precise-updates/universe armhf Packages
Hit http://ports.ubuntu.com precise-updates/main TranslationIndex
Hit http://ports.ubuntu.com precise-updates/universe TranslationIndex
Hit http://ports.ubuntu.com precise-updates/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://ports.ubuntu.com precise-updates/universe Translation-en
Hit http://www.wiimu.com pcduino Release.gpg
Hit http://www.wiimu.com pcduino Release
Hit http://www.wiimu.com pcduino/main Sources
Hit http://www.wiimu.com pcduino/main armhf Packages
Ign http://www.wiimu.com pcduino/main TranslationIndex
Ign http://www.wiimu.com pcduino/main Translation-en
Reading package lists... Done
W: Conflicting distribution: http://www.wiimu.com pcduino Release (expected pcduino but got )
root@ubuntu:~#
modify_inline.gif
 

 

 

Share this post


Link to post
Share on other sites

I "fixed" that by commenting the 2 lines that use wiimu.com in /etc/apt/sources.list.

 

I don't know if it's a very good solution, but at least I can update my system, and it seems like I can install any package I want, even without wiimu.

Share this post


Link to post
Share on other sites

So had a a similar issue. Went into /etc/apt/sources.list

 

Found the link in question: http://www.wiimu.com:8020/pcduino/- Tried view with web browser. As I have been trying on my work network, it seems blocked. 

 

Connected via a different internet source and it seems to be working. 

 

Recommendation: Check if you view the link in a web browser, if not, it might be just be a connectivity problem. For home networks - remember, you might have to open port 8020 on your router. Use www.canyouseeme.org to check if port 8020 is open.

 

Hope it helps!

Share this post


Link to post
Share on other sites

We set up a new New packages repository for pcduino. Please modify /etc/apt/sources.list 


 


As to pcDuino8 Uno, add the following line:


deb http://ubuntu.pcduino.com/pcduino8/ pcduino main

 

 


As to pcDuino3/2/1, add the following lines:


 




 


 


After that, update system:


sudo apt-get update


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×