Jump to content
Sign in to follow this  
jim

PCDuinov2 compile kernel to support GSPCA camera

Recommended Posts

Hi, I am trying to cross-compile the kernel (virtualbox ubuntu 12.04 64 bits) to include support for GSPCA cameras as module, but I am getting an error on build, so nothing is generated on output folder.
I tried to compile on the board itself and it is almost fine, generates the hwpack but do not generates the livesuit (board's linux is 32bit, and what it seems is that livesuit can be generated only in 64 bits systems).

I got some different errors, I solved some of them, seems like some git files are damaged or something, so I did a dirty job searching the missing or damaged files content to get them right.

The last error I got I am showing below:

  CC      kernel/audit_tree.o
  CC      kernel/hung_task.o
  LD      kernel/time/built-in.o
  CC      kernel/rcutiny.o
  CC      kernel/relay.o
  CC      kernel/utsname_sysctl.o
  CC      kernel/delayacct.o
  CC      kernel/taskstats.o
  CC      kernel/tsacct.o
  CC      kernel/elfcore.o
  CC      kernel/irq_work.o
  CC      kernel/cpu_pm.o
  CC      kernel/time.o
  CHK     kernel/config_data.h
  UPD     kernel/config_data.h
  CC      kernel/configs.o
  LD      kernel/built-in.o
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/home/vagrant/sunxi-bsp/kernel/linux-sunxi'
make: *** [linux] Error 2

This I got while trying to compile the kernel (after enter with make mrproper on linux-sunxi, because I got an error saying that the linux-sunxi I cloned in git was dirty).

I guess this error I showed is because this thing below:

/home/vagrant/sunxi-bsp/kernel/linux-sunxi/fs/open.c:31:23: fatal error: linux/ima.h: No such file or directory
compilation terminated.
make[3]: *** [fs/open.o] Error 1

Somebody had this problem too?

I followed this tutorial: http://learn.linksprite.com/pcduino/pcduino-embedded-linux-development/a10-based-pcduino1pcduino2pcduino-litepcduino-lite-wifi/how-to-cross-build-pcduino-kernel-on-x86-64-machine/

And please correct some things on that apt-get: include apt-get install -y libncurses5-dev pkg-config
You will need libncurses if you want to customize the kernel (make menuconfig).

Thanks for the support guys.

PS: I am using Vagrant as virtualbox provider, it is a very cool tool to work with embedded systems, it do not eat so much space in the host hard disk as a common virtual box (ubuntu 12.04 64 bits just about 300MB on disk) and it is very good for team work. If the community here will want some more information I could make a quick-and-dirty tutorial of building a box using it.

Share this post


Link to post
Share on other sites

I need c environment, but this environment which comes with default board's Linux installation is the same of this link (http://www.pcduino.com/chapter-3-c-language-and-arduino-type-ide-for-pcduino/) right?

Yes adussart, I saw so much people with problems in these kernel compile steps but the community itself does nothing to fix this too, I think there is something broken in this repo.

Share this post


Link to post
Share on other sites

I compiled it following these instructions:
http://learn.linksprite.com/pcduino/pcduino-embedded-linux-development/a10-based-pcduino1pcduino2pcduino-litepcduino-lite-wifi/how-to-cross-build-pcduino-kernel-on-x86-64-machine/

On a Ubuntu 14.04 64 bits host machine, to generate livesuit you will need this package: lib32stdc++6

But I can not boot with this generated kernel (3.4.29+) it hangs on boot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×