Jump to content
jim

Problem with pcduino-kernel in pcDuino Repository

Recommended Posts

An apt-get upgrade on the 5/31/2013 image fails with an error in the pcduino-kernel package.

Setting up pcduino-kernel (0.2) ...
/var/lib/dpkg/info/pcduino-kernel.postinst configure
dpkg: error processing pcduino-kernel (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 pcduino-kernel
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone else seeing this?

digitalhack

Share this post


Link to post
Share on other sites

lds,

Thanks, I am now able to successfully apt-get upgrade.

I did notice that I get a warning with apt-get update.  It doesn't appear to create any problems with the subsequent apt-get upgrade from what I can tell.
 

Code: [select]

Hit http://www.wiimu.com pcduino/main Sources
Hit http://www.wiimu.com pcduino/main armhf Packages
Ign http://www.wiimu.com pcduino/main TranslationIndex
Ign http://www.wiimu.com pcduino/main Translation-en
Reading package lists... Done
W: Conflicting distribution: http://www.wiimu.com pcduino Release (expected pcduino but got )
digitalhack

Share this post


Link to post
Share on other sites

ooks like the problem is wiimu.com.
After 5 minutes i get the first image on the page, and after another 5 minutes i see near of the whole page.
But with this slow speed i can't make "apt-get update" sad.gif

Share this post


Link to post
Share on other sites

BOBmoraine,

Very interesting.  For what it is worth from the DC Metro area via Verizon FIOS I get an average response time to the site of 230 ms and the website is pretty snappy.

digitalhack

Share this post


Link to post
Share on other sites

Since this seems to be the only thread in which it is even mentioned, what the heck is wiimu.com? I've done some research, discovered it is a Chinese website registered to a someone in California, but I want to know what it is and why it's in sources.list.

Thanks in advance for any information.

Share this post


Link to post
Share on other sites

I get the same error after installing a fresh Ubuntu (pcduino_ubuntu_20131126) on PCDuino V2.
 The board is pretty much useless. 

Jim, can you please check what is happening with the wiimu server?

Share this post


Link to post
Share on other sites

This problem still exist with Ubuntu  2-6-2015 release.

 

Now I can't do anything with apt-get. How to fix this? Is the only solution to reinstall Ubunto from SD card?

Share this post


Link to post
Share on other sites

Any update on that ?? I installed the pcduino3_livesuit_ubuntu14_gbpsmac_20141231 and I cant do apt-get update or upgrade.

 

Error while connecting to server?

 

Any update could be nice. 

 

Thanks 

Share this post


Link to post
Share on other sites

Any update on that ?? I installed the pcduino3_livesuit_ubuntu14_gbpsmac_20141231 and I cant do apt-get update or upgrade.

 

Error while connecting to server?

 

Any update could be nice. 

 

Thanks 

 

Try this

sudo vi /etc/apt/sources.list

and then make sure uncomment the `wiimu.com' lines and add 'trusty-security / trusty-updates' sources as downbelow

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main universe

deb http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe

deb http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe

# deb http://www.wiimu.com:8020/pcduino/ pcduino main
# deb-src http://www.wiimu.com:8020/pcduino/ pcduino main

then do 

sudo apt-get update

again, everything works well without annoying 'conflict' or 'pcduino-kernel error' blah blah

Share this post


Link to post
Share on other sites

Try this

sudo vi /etc/apt/sources.list

and then make sure uncomment the `wiimu.com' lines and add 'trusty-security / trusty-updates' sources as downbelow

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main universe

deb http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe

deb http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe

# deb http://www.wiimu.com:8020/pcduino/ pcduino main
# deb-src http://www.wiimu.com:8020/pcduino/ pcduino main

then do 

sudo apt-get update

again, everything works well without annoying 'conflict' or 'pcduino-kernel error' blah blah

 

 

First of all, I had modified the source.list for apt-get because of another information in thoses forums:

http://learn.linkspr...-04lts-precise/

 

I modified all my lines like:

 

deb http://ports.ubuntu.com/ubuntu-ports/precise main universe

 

for:

 

deb http://ports.ubuntu.com/ubuntu-ports/trusty main universe

 

This must not be done!!

Why? Because all upgrade was successfull and everything works great, until I install gdebi package (to install package graphically). Then my X windows sessions was a black screen. I tried many things and understood that LXDE was running but not displaying anything (I could use Ctrl+Alt+F1 to see it) and this is because gdebi package from trusty source is NOT compatible with the pcduino kernel provided (although upgraded to 14.04.5LTS)

 

So DON'T USE trusty. I burnt many times NAND and kernel and reinstalled everything and tested many things and that is my conclusion.

 

I had the ID keys mismatch only with trusty sources (Lubuntu 14.04), no problem with precise sources (Lubuntu 12.04) and gdebi install produced a black screen everytimes, you can't no more use your pcduino unless all reinstalling from scratch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×