Jump to content
LS-Support-12

Installing Lubuntu 14 using dd method fails.

Recommended Posts

I am trying to burn the Lubuntu 14 NAND image using Ubuntu with dd method. I manage to burn it successfully. After I install it (led is blinking some time and stops), it does not want to boot. Did anyone managed to install Lubuntu 14 using dd method?

 

I am entering these commands in terminal:

 

sudo dd if=imagelocation of=microSDlocation bs=1M

 

My microSD card is Transcend 16GB. I manage to install Ubuntu 12 using dd and Lubuntu 14 using Windows, so the memory card looks fine.

Share this post


Link to post
Share on other sites

Hi !

 

using dd on linux works !

 

In my case the device (SD card 16GB) is on sdf

Do not mount this device, if it is mounted umount it

I my case I had to prepare the partition on SD card, I used gparted to delete the partiton on /dev/sdf and create a new fullsize fat32 partition. Formati it and make it bootable.

When tis done, do the following command in your terminal:

sudo dd if=Ubuntu_14_image.img of=/dev/sdf

the image is ~1.9GB, so it takes a few minutes to copy the image, means youll have to wait a few minutes.

When this is done you can mount dev/sdf1 in any folder you want (/media/) and check if there are files on this partition

Then umount it.

Then remove the SDCARD from your computer.

Enter the SDcard to PCDUINO3 card slot.

Power ON the PCDUINO3.

TX LED must be blinking (this process is in minutes, so you ll have to wait few minutes to finish)

When TX is not blinking anymore unplug the pcduino from power.

Remove the SDcard.

Attach the MONITOR to PCDUINO.

Attach the power cable back to PCDUINO.

 

In my case it didn work for the first time. I again inserted the SDcard into pcduino to flash it again and waited few minutes so the TX led stopped blinking.

The second time it worked.

 

It booted to Lubutnu 14.

Share this post


Link to post
Share on other sites

Hi!

 

I have also did it yesterday and it works.

Which version of Ubuntu 14 did you use ?

I used the 01-07-2015 Ubuntu NAND image and flash it to the SD card using dd on a Ubuntu machine.

 

But I have two issues then and I am also interested to know if you faced the same :

  1. I cannot upgrade the distro otherwise, the kernel upgrading process failed and then block any apt-get install operation (firstly it asks for the SD card to be inserted then it looks for the uImage file...)
  2. I cannot use the Ethernet connexion. I got stuck while obtaining the IP address. But Wifi works

Romain

Share this post


Link to post
Share on other sites

I used the same version of ubuntu 14 as you did. I didint upgrade my distro but I successfully installed firefox.

apt-get install firefox

my internet connection (wired connection) works.

I didnt try to upgrade the distro with :

apt-get dist-upgrade

Before I do that I will first make a clone image of nand Ubuntu14. And than hopefully run Ubuntu 14 from SDcard and not from nand. Then when this is dune I will mzbe try what you have tryed --> upgrading the distro.

Share this post


Link to post
Share on other sites

I think wicd is loaded by default at bootup process.  And I think it just works. Its a bit weird. I am in block/apprtment in campus for students. Which means have to have a wired connection to access the internet. I have  two compurters connected to a network hub or switch not a router. These to computeres need to have the same MAC address if I want to connect from any of the to computers. One is a normal pc and the other computer is a pcduino3, both connected to a hub and what I did is the following.

 

I had to change the MAC so I have a script that chnages the MAC in ubuntu 14, because on ubuntu 12.04 this didnt work well I changed the script.bin file in nanda partition to have the dynamic MAC set.

 

I also added the line to chenge the mac in /etc/network/interfaces file.

 

I this moment I still have to run my script to change the mac each time, wicid show some default MAC while ifconfig shows the mac I set with my script. So I dont know if setting dynamic MAC address in script.bin changes anything. Also I dont know if line in interfaces file works or not. But when I run the script to chnage the mac it just works it connects.

 

The weirdest part is that it should connect thrue a secured WPA2 network with *.pem file and with wicd this is not posible. But maybe beacuse the orther computer already is conected with WPA2 and a *.pem file the pcduino is on same mac address maybe this is the reason that pcduino can connect to students nework without WPA2 scurity password.

 

Anyway I think I just confuse you with all this. So try to bring down the netwrok by entering in LX terminal this:

ifdown eth0

and then put it up again with this command

ifup eth0

I will post my configuration, I just have to start pcduino 3 ...brb

Share this post


Link to post
Share on other sites

I also confirm that this method now works.

 

However, I also cannot use ethernet connection. Problem is the same. When trying to connect using wicd, it is obtaining IP address forever.

 

b0f00nmanjaro, how do you connect to ethernet, using wicd or?

Is it the DNS issue?

Share this post


Link to post
Share on other sites

I change my MAC with this script

#!/bin/bash
ifdown eth0
ifconfig eth0 hw ether MACADRESS
ifup eth0

MAybe wicd has to be stopped and started... you just type this in lxterminal, line by line, each line press enter

/etc/init.d/wicd stop
/etc/init.d/wicd status
/etc/init.d/wicd start
/etc/init.d/wicd status

I mycase I added in script.bin:

[dynamic]
MAC yourmacaddress

But mysteps mainly explain how to change the mac..hmm...I think I m not being helpfull...

 

My /etc/network/interfaces is :

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto eth0
iface eth0 inet dhcp
	hwaddress ether yourmacaddress

Share this post


Link to post
Share on other sites

I am not sure. While attemting to connect using wicd it lasts forever (obtaining IP address). At the end it just says that it "failed to obtain IP address".

Try setting a static IP address and see if everything works normally.

Share this post


Link to post
Share on other sites

Well I am at a loss, using the instructions here and elsewhere I have created an SD Card using images with dd, win32diskimager, Phoenixcard but they all give me the same result on my PCDuino3B.

 

I insert the SD card, power up and I get slow TX blinking for a couple of minutes then rapid TX blinking, which according to the instructions means the write failed.  Done this many times now.

 

Anyone have any ideas that I can try?

Share this post


Link to post
Share on other sites

My first question is usually about the power supply.  I assume you had pcDuino3B running previously with this power supply?

 

I finally got it to work, I had to do the two part install, kernel on SD card, Ubuntu on Flash Drive, the two in one version was not working at all for me.  All up and runing now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×