Jump to content
Sign in to follow this  
chain

Cottonwood rfid reader

Recommended Posts

I bought a cottonwood rfid reader, and the windows 7 application that's linked form your web site won't work - it complains about the board having the wrong revision of firmware.

What do I need to do to make this work?
 

Share this post


Link to post
Share on other sites
Guest Steve

It's the UART version. I'm using an FTDI serial port interface (5V level)

 

When I try to add the reader using readefr_tools.exe, I get the message:

 

"The firmware version running on reader UNKNOWN 00-00-00-01 does not correspond with this software version." (plus more)

 

I have looked at the information at the link you sent, and confirmed that the UART TX and RX are correctly connected.

 

I don't know what it means, but the LED marked D1 under U1 blinks fast all the time when the board is powered up.

 

Thanks for any help

 

Share this post


Link to post
Share on other sites

It's the UART version. I'm using an FTDI serial port interface (5V level)

 

When I try to add the reader using readefr_tools.exe, I get the message:

 

"The firmware version running on reader UNKNOWN 00-00-00-01 does not correspond with this software version." (plus more)

 

I have looked at the information at the link you sent, and confirmed that the UART TX and RX are correctly connected.

 

I don't know what it means, but the LED marked D1 under U1 blinks fast all the time when the board is powered up.

 

Thanks for any help

Yes, the LED blinks when the board is powered up, its normal.

 

You can use an serial assistant to test your board. 

Share this post


Link to post
Share on other sites

I found the reason why the windows application does not work.

The reader works at 9600 baud, not 115200 as stated in all the documents and example code.

Which baud rate should the reader be using?

Is there a way to change it to the higher rate?

Share this post


Link to post
Share on other sites

I found the reason why the windows application does not work.

 

The reader works at 9600 baud, not 115200 as stated in all the documents and example code.

 

Which baud rate should the reader be using?

 

Is there a way to change it to the higher rate?

You can program the board to 115200 baud rate.

 

Please refer to http://learn.linkspr...he-rfid-reader/

 

The schematic of the little green convert pcb is as below:

 

c8051

Share this post


Link to post
Share on other sites

I also find that using your 5dBi antenna and these tags (http://store.linksprite.com/key-tag-uhf-rfid-tag-epc-gen2-900mhz/), I can only read at a maximum distance of 8cm and usually only 4cm, with the antenna in free space.

 

What orientation of the antenna should be used to maximize reading distance?

You use the 5dBi antenna, it can read maximum 5CMX5CM range. 

Share this post


Link to post
Share on other sites

I'm finishing my engineer career and have bought a cottonwood reader with debugger and adaptor, like is shown in the picture.

 

I couldn't write the firmware to the reader, and we lost 15 days without finding the problem. Until we check the resistor value in the TTL to USB Module (UART-USB), and it was 330 ohm. Changing the resistor with a 10 kohm one and it worked perfectly.

 

I recommend to check the resistor value if you have an error in the pc-reader connection.

 

Thanks for your useful help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×