Jump to content
swingzazou

halt (reboot) process seems to be not completely done

Recommended Posts

Hi,

 

I have solved shutdown issue (Lubuntu14) by following Muhammed video on Youtube. Thanks a lot to him.

But, since i have wifi connected my pcduino, the halt (reboot) process seems to be not completely done :

*Action 'stop' is meaningless for this init script       OK

*Stoppping rsync daemon rsync                            OK

*Stopping Network connection manager wicd        OK

*Asking all reamining processes to terminate...       OK

*All processes ended within 1 seconds...                OK

 

and nothing more.  The tx rx still on...

 

Thank you very much.

 

--

Serge Sauton

Share this post


Link to post
Share on other sites

Thank you Torey for the link but it refers to the first problem that i solved (linaro user did'nt have the right to shutdown, reboot etc.)

Now, the problem is different. The halt reboot is initiated but it stops (lights tx rx remain on) there not like as the begining (i heard the power turns off).

Share this post


Link to post
Share on other sites
I have solved shutdown issue (Lubuntu14) by following...

I have seen your comment on YouTube and I liked it. However (unlike two other comments before on the same video), it is not possible to reply to your comment which is quite weird. I am planning to see what is wrong in there. In the meantime, we can continue that conversation here of course. :)

 

Now, regarding the issue... Have you tried to use the solution without wifi connected? Is the behaviour same or the pcDuino turns off successfully?

Share this post


Link to post
Share on other sites

Hi,

 

I am going to be more precise :). I use wicd for the wifi connection.

With wicd we can set the option "automatically connect to this network". If the option is on or is off, the issue is'nt the same !

I have tried differents "configurations" with this option :

option : on

-> wifi connected, the reboot process stop...(the system don't fully stop, leds tx and rx still on)

-> wifi "manually" disconnected, the same issue.

option : off

-> the first reboot idem

-> after the second time i reboot, all is ok !

 

If i use sudo in a terminal command, it does'nt change anything...

Thank you very much.

Share this post


Link to post
Share on other sites

The problem is'nt solved but i'm sure that :

- if i activate "automatically connect to this network" with Wicd, the system don't stop completly (cf first post)

- if i dont' activate this option, it normally stops.

Somebody could help ?

Maybe find wich process to manually halt before stopping the system with the gui command ?

Thank you.

Share this post


Link to post
Share on other sites

The rootfs is from linaro alip, a minimized ubuntu distribution, so it may not be that robust as our PC.

I desktop of linux is full of traps. I'. working on linux 4.x and ubuntu on pcduino3 nano and will look into it after my system is set up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×