Jump to content
Sign in to follow this  
DarthBane

Underclocking

Recommended Posts

So, I have managed to get the pcduino3 nano to boot from harddrive, that was tricky. Installed lightpd, I am getting the webserver set up. Fixed the screenblanking with xfce4-power-manager. All this from the tricky set up of originally copying to sdcard, installing update-manager and "do-release-upgrade" which brought me up to Ubuntu 14.04.3 LTS.

 

My laptop died not too long after that which caused a lull in posting or working. But I liked the pcduino3 nano so much... I simply bought another one for use as a computer in developing the webserver!

 

The only shortcoming I have noticed so far... Not on the webserver is that too much CPU use causes a jittery screen and hang. Thus, I need to find a way to underclock in true bane style. There must be some easy fix out there besides recompiling a kernel... Right? Naturally I will most likely find it.

 

Let me cover some of the hings I have tried:

CPU freq applets (epic fail)

CPUfreq utils (epic fail)

The problem is that the drivers that come with cpufreq-utils are designed for x86 processors. Unless there is something I have overlooked.

Anyone have the tenacity to try this?

I hope so...

 

The latest idea I have had is to compile tlp from source. Anyone else have any other ideas?

Oh another tip... If you surf the internet, I recommend Netsurf. Low memory and CPU use overhead.

Share this post


Link to post
Share on other sites

Try my image / kernel. It come with CPU frequency scaling 480-1010Mhz and interactive governor ... and many other features. If you really want, you can also build everything from sources.

 

http://www.armbian.com/pcduino3/

I might just do that. It sure will save having to use cpulimit all the time.

I have so many grandiose plans, it is getting frustrating materializing them fast enough.

 

Thank you, Igor

Share this post


Link to post
Share on other sites

 

 

Ok. Thank you.

 

Just an update while I am fiddling with the kernel stuff...

 

The quick fix is this:

 

sudo su

<enter your password, ubuntu if you have not changed it>

 

apt-get install htop cpulimit

 

Open two terminals (ctrl-alt-t twice)

under the first type:

htop

the second, sudo su <password>

Search for the pid of lightdm (this will filter into all child processes as well)

Then enter the pid you found into this command (must be done as root!):

cpulimit -b -l 50 -p <the number of the pid you found with htop>

 

Alternately if you are psycho like me and just want to superlimit the entire f'n system:

cpulimit -b -l 50 -p 1

Thats right.. 1. That is the parent process for all other processes and the golden bullet. The first process is always 1.

Now keep in mind this is the first time I am using the heat sink on the development system that I am working and connecting to the webserver with. the pcduino3 nano webserver has a highspeed fan that pushs a lot of air. I am seriously thinking of pulling the heatskink off as I am almost convinced it is- not worth it.

So that might just be the golden bullet for any possible cpu overheating problems.

50% is what I found was stable load with the heatsink.

So far so good.. up 45 minutes with no crash.

Share this post


Link to post
Share on other sites

It looks like this is the fix I need for the time being. After some heavy duty benchmarking it seems to have fixed the issue.

 

I readily accept the fact that it is caused by xfce4-power-manager overriding the normal power settings that are accepted or the system. I.e. what I am saying is the power options that come with both flavors of ubuntu for the pcduino3nano prevent these issues by default are designed to prevent the current situation (overheating). xfce4-power-manager overrides these. However, conclusively using cpulimit in an all inclusive capacity e.g. "cpulimit -b -l 50 -p 1" fixes this issue completely.

 

If other cpulimits settings work for other individuals in other capacities, this may be of use to other people researching the subject. Alternately, doing a build takes time and looks like it will work. However do to the lack of other computers in the current situation means time and money for the project. Once he project is up and running, the purpose in future aid to society can be revealed.

 

So, I hope this helps this community. All that is needed now is to find an appropriate init script to add the cpulimit command to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×