Jump to content
Sign in to follow this  
Zampatti

Acadia 3.0 ubuntu gpio api command

Recommended Posts

I have some problem on this board: when I set GPIO mode INPUT (Low value) on any pin (I tried pin 0 to 11) it does not applied. I made setting  through linux command "echo '0' > gpioXX" in the directory "/sys/devices/virtual/misc/gpio/mode".

Furthermore when I set GPIO10 pin LOW in the directory "/sys/devices/virtual/misc/gpio/pin" the same setting is automatically made in the ../mode/GPIO10 file.

I have tried OUTPUT setting on pin 4, 7 and 8 and all the corresponding hardware pins function properly.

Please how can I set pin 10, or another, in input mode?

Thanks

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×