Jump to content
Sign in to follow this  

New packages repository for pcduino

Recommended Posts

We set up a new packages repository for pcduino. Please modify /etc/apt/sources.list 


As to pcDuino8 Uno, add the following line:

deb http://ubuntu.pcduino.com/pcduino8/ pcduino main



As to pcDuino3/2/1, add the following lines:




After that, update system:

sudo apt-get update


If you have any problem, please tell me via Email:

qi.yao # linksprite.com

Share this post

Link to post
Share on other sites
Guest hamberger

this is what I get - 


root@linaro-alip:/etc/apt# cat /etc/apt/sources.list
deb-src http://ports.ubuntu.com/ubuntu-ports/trusty main universe
root@linaro-alip:/etc/apt# apt-get update
Hit http://repo.linaro.orgtrusty InRelease
Hit http://ppa.launchpad.nettrusty InRelease                                                                           
Hit http://repo.linaro.orgtrusty/main Sources                                                                          
Hit http://repo.linaro.orgtrusty/main armhf Packages                                                                   
Hit http://ppa.launchpad.nettrusty/main Sources                                
Ign http://repo.linaro.orgtrusty/main Translation-en                           
Ign http://ubuntu.pcduino.compcduino InRelease                                 
Hit http://ppa.launchpad.nettrusty/main armhf Packages                         
Hit http://ubuntu.pcduino.compcduino Release.gpg         
Hit http://ubuntu.pcduino.compcduino Release             
Hit http://ppa.launchpad.nettrusty/main/debug armhf Packages                  
Hit http://ppa.launchpad.nettrusty/main Translation-en   
Hit http://ubuntu.pcduino.compcduino/main armhf Packages 
Ign http://ubuntu.pcduino.compcduino/main Translation-en 
Ign http://ports.ubuntu.comtrusty InRelease              
Hit http://ports.ubuntu.comtrusty Release.gpg
Hit http://ports.ubuntu.comtrusty Release
Hit http://ports.ubuntu.comtrusty/main Sources
Hit http://ports.ubuntu.comtrusty/universe Sources
Hit http://ports.ubuntu.comtrusty/main armhf Packages
Hit http://ports.ubuntu.comtrusty/universe armhf Packages
Hit http://ports.ubuntu.comtrusty/main Translation-en
Hit http://ports.ubuntu.comtrusty/universe Translation-en
Reading package lists... Done
W: Conflicting distribution: http://ubuntu.pcduino.compcduino Release (expected pcduino but got )

Share this post

Link to post
Share on other sites
Guest SpaceInvader


Thank you for replying.


I yet have tried the solution you mentioned before going here posting my problem, since I searched with internet when having this trouble. But this doesn't work, there is a conflict of distribution, I can't.


Last time I did it there was a conflict distribution error (with the 3.4.79+ Linaro/Lubuntu distrubution pre-installed within my pcDuino3 nano updated up to Linaro 12.11 version); and now, I have burnt a NAND image and Ubuntu kernel image with one of your procedures with SD card and USB flask disk:


I used this NAND:

And this kernel:


So that you know exactly with what system version I run when having conflict. I only made a "sudo apt-get update"  one time with this fresh installation and a geany installation to edit the file with "sudo apt-get install geany --yes" and I got too another conflict distribution with the modification you indicated, but different this time, I have an indication of conflict ID key (I had not this conflict ID number with the same modification of sources with the preinstalled kernel inside the pcduino, I only had a conflict version error with nothing else):



I modified the sources:

sudo geany /etc/apt/sources.list


So I have this version for the "sources.list" file:

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main universe
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe
deb http://ubuntu.pcduino.com/pcduino3/ pcduino main
deb-src http://ubuntu.pcduino.com/pcduino3/ pcduino main



I put the update command then:

sudo apt-get update



So I had the new conflict error with ID keys:


Ign http://ppa.launchpad.net precise InRelease
Hit http://ppa.launchpad.net precise Release.gpg                               
Hit http://ppa.launchpad.net precise Release                                   
Ign http://ports.ubuntu.com trusty InRelease                               
Get:1 http://ports.ubuntu.com trusty-security InRelease [65.9 kB]          
Hit http://ppa.launchpad.net precise/main Sources                              
Hit http://ppa.launchpad.net precise/main armhf Packages                       
Ign http://ppa.launchpad.net precise/main TranslationIndex                     
Get:2 http://ports.ubuntu.com trusty-updates InRelease [65.9 kB]               
Ign http://ppa.launchpad.net precise/main Translation-en                       
Get:3 http://ports.ubuntu.com trusty Release.gpg [933 B]                       
Ign http://ubuntu.pcduino.com pcduino InRelease                                
Get:4 http://ports.ubuntu.com trusty-security/main Sources [123 kB]
Get:5 http://ports.ubuntu.com trusty-security/universe Sources [46.5 kB]
Get:6 http://ports.ubuntu.com trusty-security/main armhf Packages [487 kB]     
Get:7 http://ubuntu.pcduino.com pcduino Release.gpg [836 B]               
Get:8 http://ubuntu.pcduino.com pcduino Release [1306 B]                       
Get:9 http://ports.ubuntu.com trusty-security/universe armhf Packages [145 kB] 
Get:10 http://ubuntu.pcduino.com pcduino/main Sources [1101 B]               
Get:11 http://ports.ubuntu.com trusty-security/main TranslationIndex [208 B] 
Get:12 http://ports.ubuntu.com trusty-security/universe TranslationIndex [205 B]
Get:13 http://ports.ubuntu.com trusty Release [58.5 kB]    
Get:14 http://ports.ubuntu.com trusty-updates/main Sources [388 kB]            
Get:15 http://ubuntu.pcduino.com pcduino/main armhf Packages [5671 B]          
Ign http://ubuntu.pcduino.com pcduino/main TranslationIndex                    
Get:16 http://ports.ubuntu.com trusty-updates/universe Sources [170 kB]
Get:17 http://ports.ubuntu.com trusty-updates/main armhf Packages [808 kB]    
Ign http://ubuntu.pcduino.com pcduino/main Translation-en                      
Get:18 http://ports.ubuntu.com trusty-updates/universe armhf Packages [383 kB] 
Get:19 http://ports.ubuntu.com trusty-updates/main TranslationIndex [208 B]    
Get:20 http://ports.ubuntu.com trusty-updates/universe TranslationIndex [208 B]
Get:21 http://ports.ubuntu.com trusty-security/main Translation-en [314 kB]    
Get:22 http://ports.ubuntu.com trusty-security/universe Translation-en [86.6 kB]
Get:23 http://ports.ubuntu.com trusty/main Sources [1064 kB]                   
Get:24 http://ports.ubuntu.com trusty/universe Sources [6399 kB]               
Get:25 http://ports.ubuntu.com trusty/main armhf Packages [1295 kB]            
Get:26 http://ports.ubuntu.com trusty/universe armhf Packages [5710 kB]        
Get:27 http://ports.ubuntu.com trusty/main TranslationIndex [3632 B]           
Get:28 http://ports.ubuntu.com trusty/universe TranslationIndex [3129 B]       
Get:29 http://ports.ubuntu.com trusty-updates/main Translation-en [457 kB]     
Get:30 http://ports.ubuntu.com trusty-updates/universe Translation-en [207 kB] 
Get:31 http://ports.ubuntu.com trusty/main Translation-en [762 kB]             
Get:32 http://ports.ubuntu.com trusty/universe Translation-en [4089 kB]        
Fetched 23.1 MB in 1min 36s (240 kB/s)                                         
Reading package lists... Done
W: There is no public key available for the following key IDs:
W: There is no public key available for the following key IDs:
W: Conflicting distribution: http://ubuntu.pcduino.com pcduino Release (expected pcduino but got )
W: There is no public key available for the following key IDs:





So the problem still resides.

With what NAND and kernel version is the new package compatible with? With this solution there will not be any conflict problem.


Thank you for your answer.

Share this post

Link to post
Share on other sites
Guest SpaceInvader

I was answering with my last post to the problem for which I am here and where youkee answered me:



(Sorry but forum linksprite forbids me to post as a logged in user in the previous topic and I could only post as a guest in this current topic)

Share this post

Link to post
Share on other sites

1) First of all, I had modified the source.list for apt-get because of another information in thoses forums:



I modified all my lines like:


deb http://ports.ubuntu.com/ubuntu-ports/precise main universe




deb http://ports.ubuntu.com/ubuntu-ports/trusty main universe


This must not be done!!

Why? Because all upgrade was successfull and everything works great, until I install gdebi package (to install package graphically). Then my X windows sessions was a black screen. I tried many things and understood that LXDE was running but not displaying anything (I could use Ctrl+Alt+F1 to see it) and this is because gdebi package from trusty source is NOT compatible with the pcduino kernel provided (although upgraded to 14.04.5LTS), changes some X server configuration and ... X server gives a black screen. But gdebi is not the only one. I installed too pavucontrol after going on 14.04 and then... the same black screen. We obtain black screen with some updates of packages concernong X windows and then pcduino won't work any longer. Stay with 12.04.


So DON'T USE trusty first (you can install gdebi first with precise sources, pavucontrol, in Lubuntu 12.04 and then upgrade to trusty after, then no black screen occurs, but don't install anything else afeter going on 14.04 unless you have the risk of black screen). I burnt many times NAND and kernel and reinstalled everything and testes many things and that is my conclusion.


I had the ID keys mismatch only with trusty sources (Lubuntu 14.04), no problem with precise sources (Lubuntu 12.04)


2)Second thing: I found the problem, why there is a distribution conflict when using the lines added to sources.list:

deb http://ubuntu.pcduino.com/pcduino3/ pcduino main
deb-src http://ubuntu.pcduino.com/pcduino3/ pcduino main

the line "deb http://ubuntu.pcduino.com/pcduino3/ pcduino main"  refers to the url:



The first part: "http://ubuntu.pcduino.com/pcduino3/"is the base url, then you have a space between this base url and pcduino, it means that you must have a subdir named "dists", then you have another space between pcduino and main, thos means that you access the subdir and file "main/source/Sources". This is the way source packages are meant to be built.


The file "Sources" lists all the files in the subdir "source" and their size and checksum.

So it gives you access to the files in the subdir "source".


But if you see what is at the target url ""http://ubuntu.pcduino.com/pcduino3/dists/pcduino/main/source/"

we have:

Sources                                            02-Dec-2016 15:07    1101
pcduino-dev_0.1-1.debian.tar.gz                    02-Dec-2016 15:07     10K
pcduino-dev_0.1-1.dsc                              02-Dec-2016 15:07    1723
pcduino-dev_0.1-1_source.changes                   02-Dec-2016 15:07    2143
pcduino-dev_0.1.orig.tar.gz                        02-Dec-2016 15:07     46K

And nothing of those files are the kernel files for pcduino3. So there is a problem.

But I could find the right files in another subdir:




Here we can list files:

Packages                                           02-Dec-2016 15:07    5671
pcduino-arduino-ide_0.1_armhf.deb                  02-Dec-2016 15:07     10M
pcduino-arduino-ide_0.2_armhf.deb                  02-Dec-2016 15:07     10M
pcduino-cloud9_0.1_armhf.deb                       02-Dec-2016 15:07     33M
pcduino-config_0.1_armhf.deb                       02-Dec-2016 15:07    9318
pcduino-config_0.2_armhf.deb                       02-Dec-2016 15:07     11K
pcduino-dev_0.1_armhf.deb                          02-Dec-2016 15:07    169K
pcduino-kernel_0.1_armhf.deb                       02-Dec-2016 15:07      9M
pcduino-kernel_0.2_armhf.deb                       02-Dec-2016 15:07      9M
pcduino-kernel_0.3_armhf.deb                       02-Dec-2016 15:07      9M
pcduino-linux-headers-3.4.29+_0.1_armhf.deb        02-Dec-2016 15:07      7M
pcduino-linux-headers-3.4.79+_0.1_armhf.deb        02-Dec-2016 15:07      7M
pcduino-scratch_0.1_armhf.deb                      02-Dec-2016 15:07     38M
pcduino-scratch_0.2_armhf.deb                      02-Dec-2016 15:07     38M
pcduino-scratch_0.4_armhf.deb                      02-Dec-2016 15:07     38M
pcduino-squeak_0.1_armhf.deb                       02-Dec-2016 15:07    747K
pcduino-xbmc_0.1_armhf.deb                         02-Dec-2016 15:07     29M
pcduino-xbmc_0.2_armhf.deb                         02-Dec-2016 15:07     29M
pcduino-xbmc_0.3_armhf.deb                         02-Dec-2016 15:07     29M
pcduino_0.1_armhf.deb                              02-Dec-2016 15:07     782
pcduino_0.2_armhf.deb                              02-Dec-2016 15:07     784
pcduino_0.3_armhf.deb                              02-Dec-2016 15:07     756

We can see that the kernel files for pcduino3 is here: "pcduino-kernel_0.1_armhf.deb " and the headers sources for compiling kernel 3.4.79+ to compile your drivers is here too "pcduino-linux-headers-3.4.79+_0.1_armhf.deb".


So all is here. But we can't access it because it is at the wrong place.

So, if an admin here could replace the files at the correct place the firts post of this topic would be a suefull instruction since the apt-get sources would be right.


I can say that those files are the right ones, since I downloaded the headers for 3.4.79+ and could use them. So if no admin action is taken to repair the wrong file place, you can do it like me:


Use your Chromium web browser in Lubuntu 12 of your pcduino to download the package you want (for me the headers of the kernel):



(or use a wget command line instruction if you wish), and then install the package you just downloaded (I installed it in graphic mode with gdedi and double click on the .deb file) and then ... it works!


If you just want to laucnh command lines to do it with no search of what to do, I put here the instructions:

cd Downloads
wget -4 http://ubuntu.pcduino.com/pcduino3/dists/pcduino/main/binary-armhf/pcduino-linux-headers-3.4.79%2B_0.1_armhf.deb

When download is finished, then install package:

sudo dpkg -i pcduino-linux-headers-3.4.79+_0.1_armhf.deb

This can solve the issue for all those like me who try to install 3.4.79+ headers for pcduino from wiimu sources no longer available.


If admin solve the wrong place files of source package, the procedure I wrote here will not be usefull.

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this