Jump to content

Questions about Narrow band PLC with simple Mac

Recommended Posts

Hi. I just got 3 modules. I am unable to get anything going on these units.
I connected both units to 15Vdc on VHH.
I connected the ac plugs together with some wire.
I measure 5V on the +5VOUT pin, so I assume the module is powered.

I set up the comms to Module 1 for 19200 8N1 on pin RXD. No connection on TXD.

I measure with scope on RXD to see that data comes in.
I measure with scope on AC, I see no carrier signal on the ac. (There is no mains connected to the AC line yet)
I measure on module 2, TXD pin. The TXD pin stays at 5v, dropping to 0v every few seconds for 320ms.

I tried sending a character at a time.
I tried sending a few characters at a time.

From the user manual I see that the module works in packets of 20 characters. Is there a framing character that is sent to denote the start or end of the package, i.e cr or lf ?

I have tried different comms programs.
First I connected with a PIC micro processor that sends some data at 19200 baud.
Then I tried using Hyperterminal and a board using a FT232 chip that gives out ttl 5v signals.
I then installed X-CTU, transmitting via the same FT232 chip.

The data arrives at the module, but does not go any further.

Please Help? I desperately want to get this module to work.


Share this post

Link to post
Share on other sites
Guest Matt


I attempted to do this exact and nothing works. When using my terminal on the PC to send serial data to the Arduino when the two Arduino's TX/RX (TX1->RX2 & RX1->TX2) are directly connected together the data is transmitted correctly. But, when the serial data is going through two SimpleMAC modules and then the power line (PC -> Arduino -> SimpleMac -> power line -> SimpleMac -> Arduino -> PC) there is no data transmitted between the two. Can either of you be explicit about how you got data to transfer between the two? The boards are marketed as being able to simply accept serial at 19200 but I haven't seen that to be the case.

Share this post

Link to post
Share on other sites

MacBook Pro Terminal.app viewing/sending serial at 19200 baud -> Arduino (without ATMega) -> Linksprite narrow band PLC with Simple MAC board -> power cable to power strip -> power cable to power strip -> Simple MAC board -> Arduino (without ATMega) -> MacBook Pro Terminal.app viewing/sending serial at 19200 baud


Configuration from both Ardiuno to the paired Simple MAC:

Simple MAC  TXD – > Arduino D1

Simple MAC RXD – > Arduino D0

Simple MAC GND – > Arduino GND
Simple MAC AC interface – > Power cord


Using with a 3 prong outlet, we've tried all three configurations: 1 wire on post + 1 wire on GND post, the alternate configuration, and 1 wire on both hot posts. Power strip plugged into the wall and turned on. Both boards are being given 120 V and give a 5 V reading on their 5V out pin. No configuration has been able to receive data. When we don't change anything except removing the Simple MAC board and connect the serial of the two Arduino boards together, everything works correctly.


Anymore information that would be relevant?

Share this post

Link to post
Share on other sites

Hi Mattrob,


Did you ever get it working?

I'm interested in trying this module, too, but have read two failure stories now...

I guess it must be able to work, and the concept sounds great!

Looking forward to hearing from you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now